Opened 12 years ago

Closed 12 years ago

#4093 closed Feature request (worksforme)

allowing domains to access via IP List

Reported by: mcsnoop Owned by: domains access IP list allow extern
Priority: normal Component: FileZilla Server
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP Prof

Description

Hi everyone,

I disabled under IP Filter all extern access in the Top IP Box.
In the second Box I could exclude/enabled some IPs. Intranet and some People I allow the Access from extern IPs.

But in the DSL century the IP from my persons are changed every day, so I created for everyone an DynDNS Domain Acc.

But in the exclusion Field no Domains are excepted.

It is possible to implement this?

regards
McSnoop

Change History (5)

comment:1 by Tim Kosse, 12 years ago

Resolution: worksforme
Status: newclosed

You can use regular expressions. Note that you can only use rDNS for performance reasons.

comment:2 by mcsnoop, 12 years ago

Resolution: worksforme
Status: closedreopened

The answer doesn't helps.

What are the regular expressions? rDNS->reverseDNS? If yes, in the options no rDNS.

The problem is that the IP changes and just the domain is the same. But the Filter doesn't accept domain names.

comment:3 by Tim Kosse, 12 years ago

Resolution: worksforme
Status: reopenedclosed

What are the regular expressions?

http://en.wikipedia.org/wiki/Regular_expression

rDNS->reverseDNS?

Yes.

Just give your account a long and complex password and use TLS/SSL encryption, better solution than wonky hostname filters.

comment:4 by User, 12 years ago

Resolution: worksforme
Status: closedreopened

I am also looking for this feature. I need this to avoid accountshareing. Only the user who knows the login _and_ have the ip of the domain can login.

to the hint of using regex: where can i use it? inside the field "Exclude the following IPs..."?

comment:5 by Tim Kosse, 12 years ago

Resolution: worksforme
Status: reopenedclosed

Both the allow and the disallow. Note that this Trac is not a place for support requests, only for actual bug reports and feature requests. Use the forums for that.

Note: See TracTickets for help on using tickets.