Opened 12 years ago

Closed 12 years ago

Last modified 7 years ago

#4034 closed Bug report (rejected)

Version 3.1.5.1 (and 3.2.0) won't list directory but 2.2.10 does.

Reported by: RoscoHead Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP Prof SP3

Description

Here's a weird one. A site that I haven't visited using FZ for a while (I have a program that does automated download from there that works fine though). Today I connected using FZ 3.1.5.1 and it showed the remote directory as empty. I tried passive, active, force show hidden files, all with the same result. So I went to another machine on the same network that hasn't been upgraded from 2.2.10 yet, and it displays the files fine.

Debug logs are attached, grateful for any pointers.

ROSCO

Attachments (3)

FZ3151.txt (1.6 KB ) - added by RoscoHead 12 years ago.
Log from FZ 3.1.5.1
FZ2210.txt (2.1 KB ) - added by RoscoHead 12 years ago.
Log from FZ 2.2.10
FZ320_full.log (6.7 KB ) - added by RoscoHead 12 years ago.
Full log from 3.2.0

Download all attachments as: .zip

Change History (10)

by RoscoHead, 12 years ago

Attachment: FZ3151.txt added

Log from FZ 3.1.5.1

by RoscoHead, 12 years ago

Attachment: FZ2210.txt added

Log from FZ 2.2.10

comment:1 by Tim Kosse, 12 years ago

Status: newmoreinfo

Post complete logs. Snippets are of no use.

comment:2 by RoscoHead, 12 years ago

Status: moreinfonew

How do I get more? I set the debug level to 4, and pasted all info from the log file, what else do I need to do?

comment:3 by Tim Kosse, 12 years ago

Status: newmoreinfo

The complete logs. Everything since the start of FileZilla.

by RoscoHead, 12 years ago

Attachment: FZ320_full.log added

Full log from 3.2.0

in reply to:  3 comment:4 by RoscoHead, 12 years ago

Status: moreinfonew
Summary: Version 3.1.5.1 won't list directory but 2.2.10 does.Version 3.1.5.1 (and 3.2.0) won't list directory but 2.2.10 does.

OK, I switched on logging, closed FZ, started it again, opened the connection in question, then exited FZ. The resulting log is attached, FZ320_full.log. Note that I've upgraded to 3.2.0 since I posted the bug, and the problem is still there.

Let me know if I need to do anything else.

comment:5 by Tim Kosse, 12 years ago

Status: newmoreinfo

Nothing unusual in the log. If you enable "Show raw directory listing" in the settings, do the files get listed in the log? If so please post an example line.

comment:6 by RoscoHead, 12 years ago

Status: moreinfonew

Show raw directory listing was enabled when I did FZ320_full.log

comment:7 by Tim Kosse, 12 years ago

Resolution: rejected
Status: newclosed

Probably just a broken server. FileZilla 3 is a lot faster than 2.x and some other clients as well. According to the log the data connection gets established and closed again (the latter on behalf of the server) prior to receiving the initial reply to the LIST command. There's a good chance that the data connection establishment happens on the server prior to it receiving the LIST command.
Since you are using a proprietary server, I cannot analyze this issue further, I have to blame the server by default.

Note: See TracTickets for help on using tickets.