Opened 12 years ago

Closed 12 years ago

#4007 closed Bug report (rejected)

Failed to retrieve directory listing in v3.1.5.1 FTPES

Reported by: Bryan Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP (5.1.2600) w/ SP2 and SP3

Description

Windows XP client build 5.1.2600 w/ SP2.

Trying to connect using FZ client to a RHEL server running VSFTPD configured with FTP over explicit SSL.

Using the latest FZ client version (3.1.5.1), could connect to the server however fails trying to bring up the directory listing.

Error: Failed to retrieve directory listing

Session is using passive transfer method, however, using active transfer produces same result.

In older version of FZ client(v3.0.8.1) this connects and displays the directory listing without issue.

This has been reproduced on numerous client PCs testing both versions connecting to our server.

Attaching trace logs of both.

Appears as though something has changed when it comes to TLS in the newer version of FZ client.

Attachments (2)

fz_3081.txt (12.5 KB) - added by Bryan 12 years ago.
fz_3151.txt (6.1 KB) - added by Bryan 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Bryan

Attachment: fz_3081.txt added

Changed 12 years ago by Bryan

Attachment: fz_3151.txt added

comment:1 Changed 12 years ago by Bryan

fz_3081.txt is the trace log from FZ client v3.0.8.1 where the directory listing is fine.

fz_3151.txt is the trace log from FZ client v3.1.5.1 where the directory listing fails.

comment:2 Changed 12 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Caused by a bug in your server. You have to upgrade to vsftpd 2.0.7

See http://forum.filezilla-project.org/viewtopic.php?f=2&t=7688 for details.

Note: See TracTickets for help on using tickets.