Opened 11 years ago

Closed 10 years ago

#3967 closed Bug report (rejected)

Could not locate sftpdrive generated drives

Reported by: calvin Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Vista Home Premium (SP1)

Description

Filezilla Version: 3.1.5
SftpDrive Version: 1.7.9

I am using SftpDrive (http://www.magnetk.com/sftpdrive/) to connect a a server via sftp protocol. It builds a bridge between the server and Windows box, making the sftp connection as Network drive (I think...).

Previously (Filezilla 3.1.3.1), sftpdrives were visible in "Local Site" tree. But now they are not visible nor accessible thru Filezilla.

When I drag a file from the server to Windows Explorer with SftpDrive opened, it shows a error message:

---------------------------
Filezilla Error
---------------------------
Directory 'W:\sandbox' couldn't be created (error 3: the system cannot find the path specified.)
---------------------------
OK   
---------------------------

Steps to reproduce:

  1. Install SftpDrive and create a connection.
  2. Install Filezilla 3.1.3.1
  3. Check connected sftpdrive is visible and accessible.
  4. Remove Filezilla and install Filezilla 3.1.5
  5. Check connected sftpdrive is visible and accessible.

If you need more information, let me know

Change History (1)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

FileZilla does not do anything unusual, it simply asks Windows for a list of drives. It also uses the normal Windows API functions to access any files.

Most likely there's something wrong with your SftpDrive software. Since SftpDrive is proprietary closed source software I cannot analyze this issue any further. The burden of proof should there be something wrong with FileZilla is on your/their end.
(Proof = proper source patch)

Note: See TracTickets for help on using tickets.