Opened 11 years ago

Closed 6 years ago

Last modified 6 years ago

#3966 closed Bug report (outdated)

OpenVMS directories not correctly handled with SFTP

Reported by: Rolf Owned by:
Priority: normal Component: FileZilla Client
Keywords: OpenVMS VMS directory folders Cc:
Component version: Operating system type: Windows
Operating system version: XP Professional, SP3

Description

FileZilla client version: 3.1.5
SFTP server version OpenVMS 8.3

Part 1:
====================================================================
Using the client from Windows to a OpenVMS server. Client is configured that is talks to a VMS server.

In FileZilla the "Remote site" field read:

"[/APACHE$COMMON/SPECIFIC/REVMS]"

. It is an absolute path.
If I add "/logs" to that path, it should read:

"[/APACHE$COMMON/SPECIFIC/REVMS/logs]"

.

The log shows that FileZilla attempted to open:
"

Command:	cd "[/apache$common/specific/revms/logs]"
Error:	Directory /apache$common/specific/revms/[/apache$common/specific/revms/logs]: no such file or directory
Error:	Failed to retrieve directory listing
Status:	Retrieving directory listing...

"
The full path in the field was added to the current, and made a nonexistent path.

If I instead delete what already is shown in the field "Remote site", and just writes "logs" there, the log shows that FileZilla tries:
"

Command:	cd "[/apache$common/specific/revms.logs]"
Error:	Directory /apache$common/specific/revms/[/apache$common/specific/revms.logs]: no such file or directory
Error:	Failed to retrieve directory listing

"

If I instead of "logs" let it show "/logs" in the field, FileZilla tries :
"

Command:	cd "[/apache$common/specific/revms./logs]"
Error:	Directory /apache$common/specific/revms/[/apache$common/specific/revms./logs]: no such file or directory
Error:	Failed to retrieve directory listing

"

As I see it, when sftp is chosen, the "Remote site"-field should always be left empty by the program.
The path written there should be considered relative paths to the current, and when enter is pressed, it should be added to the current path, with an "/" as a separator.

FileZilla should not use "[]" when in sftp mode. Maybe that is the main problem?

When FTP is used the dot "." is the correct separator between levels in the folder hierarchy, but apparently not when Sftp is used.

I found out that the error does not appear when using plain FTP.
It is when using SFTP it malfunctions.

So I compared how Puttys psftp acted.
Here is a complete conversation:

"
psftp> cd /sys$sysdevice/syshome
Remote directory is now /sys$sysdevice/000000/SYSHOME

psftp> ls
Listing directory /sys$sysdevice/SYSHOME
.BASH_HISTORY;1
2ZC52FG1.EXE;1
BAND-BACKUP.COM;3
CDSA.DIR;1
DECW$ENDSESSION.DECW$XAUTH;16
DECW$TERMINAL_DEFAULT.DAT;1
DECW$TERMINAL_DEFAULT.DAT;2
DECW$XAUTHORITY.DECW$XAUTH;1
DEFS9A3O.EXE;1
LOGIN.COM;20
LOGIN.COM;21
LOGIN.COM;22
RESTART-AUDIT-BATCH.COM;3
RESTART-WEBALIZER-BATCH.COM;2
SEAREXTAPA.COM;1
SMBD_STARTUP.LOG;69
SMBD_STARTUP.LOG;7
SMBD_STARTUP.LOG;70
SMBD_STARTUP.LOG;71
SMBD_STARTUP.LOG;8
SMBD_STARTUP.LOG;9
STATS.DAT;1
SWAT_STARTUP.LOG;73
SWAT_STARTUP.LOG;74
SWAT_STARTUP.LOG;8
SWAT_STARTUP.LOG;9
SYSTARTUP_VMS_COM.TPU$JOURNAL;1
SYSTEM_REPORT.DIR;1
TCPIP$FTP_SERVER.LOG;1
TCPIP$FTP_SERVER.LOG;2
TCPIP$FTP_SERVER.LOG;3
TCPIP$FTP_SERVER.LOG;4
TCPIP$SSH_SFTP-SERVER2.LOG;1
TCPIP$SSH_SFTP-SERVER2.LOG;10
TCPIP$SSH_SFTP-SERVER2.LOG;2
TCPIP$SSH_SFTP-SERVER2.LOG;3
TCPIP$SSH_SFTP-SERVER2.LOG;4
TCPIP$SSH_SFTP-SERVER2.LOG;5
TCPIP$SSH_SFTP-SERVER2.LOG;6
TCPIP$SSH_SFTP-SERVER2.LOG;7
TCPIP$SSH_SFTP-SERVER2.LOG;8
TCPIP$SSH_SFTP-SERVER2.LOG;9
USERS.TXT;1
VUE$PROFILE.VUE$DAT;1
_MOZILLA.DIR;1
decw$sm.log;10
decw$sm.log;11
decw$sm.log;12
decw$sm.log;13
decw$sm.log;14
decw$sm.log;15
decw$sm.log;16
decw$sm.log;17
decw$sm.log;2
decw$sm.log;3
decw$sm.log;4
decw$sm.log;5
decw$sm.log;6
decw$sm.log;7
decw$sm.log;8
decw$sm.log;9
dt.DIR;1
imagebck.com;1
ssh2.DIR;1

psftp> cd /apache$common/specific
Remote directory is now /apache$common/000000/SPECIFIC

psftp> dir
Listing directory /apache$common/SPECIFIC
REVMS.DIR;1

psftp> cd revms
Remote directory is now /apache$common/SPECIFIC/REVMS

psftp> cd /APACHE$COMMON/SPECIFIC/REVMS/HTDOCS/jul
Remote directory is now /APACHE$COMMON/SPECIFIC/REVMS/HTDOCS/jul

psftp> dir
Listing directory /APACHE$COMMON/SPECIFIC/REVMS/HTDOCS/jul
2004.DIR;1
SantaClaus.gif;1
Thumbs.db;1
ZbThumbnail.info;1
clouds2.jpg;1
godjul.htm;1
himmel.GIF;1
himmel.bmp;1
index.html;1
robots.txt;1
snow.gif;1
tempfil.htm;1
tomteflykt.gif;1

psftp>
"
That works as expected!

Part 2:
====================================================================
When SFTP is used, FileZilla needs to recognize that files like *.DIR;* is lower levels of directories/folders, so that they should be listed as folders in the Remote site folder tree.

Change History (6)

comment:1 Changed 11 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #3959

comment:2 in reply to:  1 Changed 11 years ago by Rolf

Resolution: duplicate
Status: closedreopened

Replying to codesquid:

Duplicate of #3959

#3966 is not a dublicate of #3959!

FileZilla acts better with SFTP against OpenVMS when falsly informed that it is talking with an UNIX-system, than when explicitly informed that it is talking to a VMS-server.

The only thing lacking when using it as if it was with an UNIX-system you were working against, is that *.dir.1-files are not recognized as subfolders that should be shown in the Remote site folder tree.

In #3959 I was wrong about that the problem existed when using FTP. FileZilla does not manage OpenVMS servers correct in SFTP.

I can accept that this is a low priotity bug, but a bug it is.

Best regards!
Rolf Modin

comment:3 Changed 11 years ago by Tim Kosse

I still think it's the fault of the server. If it goes through all the trouble to convert the obscure VMS path syntax into Unix path syntax, why does it still display directory listings in VMS syntax?

It's like putting a propeller into the trunk of your car and then trying to fly with it.

comment:4 in reply to:  3 Changed 11 years ago by Rolf

Replying to codesquid:

I still think it's the fault of the server. If it goes through all the trouble to convert the obscure VMS path syntax into Unix path syntax, why does it still display directory listings in VMS syntax?

It's like putting a propeller into the trunk of your car and then trying to fly with it.

Well, You could think that they could do in an other way, byt they don't. And it seems that you have all the components already in your code to combine in a new way to get a working solution.

Send the cd-command as if it was to an UNIX-server, and analyze the ls-result as if it was FTP with a VMS-server.

Best regards
Rolf

comment:5 Changed 6 years ago by Alexander Schuch

Status: reopenedmoreinfo_reopened
Summary: OpenVMS directories not correctly handeld with SFTPOpenVMS directories not correctly handled with SFTP

Do you still have that problem with current version of FileZilla and a current version of the VMS FTP/SFTP server software?

comment:6 Changed 6 years ago by Alexander Schuch

Resolution: outdated
Status: moreinfo_reopenedclosed

No reply for more than 28 days.

Note: See TracTickets for help on using tickets.