Opened 11 years ago

Closed 11 years ago

Last modified 5 years ago

#3876 closed Bug report (rejected)

Filezilla's GUI in Linux (Gnome) is buggy

Reported by: SiDi Owned by:
Priority: normal Component: FileZilla Client
Keywords: linux gnome dark theme gui Cc:
Component version: Operating system type: Linux
Operating system version: Ubuntu 8.04 (with 8.10's GTK engine)

Description

Hello,

After installing a new (the default 8.10 one, with the 8.10 GTK engine : "gtk2-engines-murrine") theme on my OS (i use GNOME + Compiz), i noticed Filezilla's GUI was having trouble with it.

My problem is that the font of the text in the "file explorers" (local and remote) is light-grey, while the theme background is just... white.

On my theme, the light-grey is the text colour for taskbars and such things, which all have a dark background. The area with white background is meant to go with dark text colour.

So i think the problem is that for these text areas in Filezilla, the text color that is picked is not the one that should be used with the background colour (grey+white instead of black+white). This is likely to happen in a lot of themes, including one of the default themes of Ubuntu 8.10 coming in less than 3 weeks.

I hope you can correct this bug, it's likely to be half a line to write, but as it's pretty annoying, it'd be cool that you do it fast, or tell Ubuntu devs at launchpad.org how to solve it and add it to our repository.

Greetings, SD.

Attachments (2)

TextColor.png (166.4 KB) - added by SiDi 11 years ago.
Screenshot that shows the bug.
Capture.jpg (161.6 KB) - added by SiDi 11 years ago.
Screenshot that shows even more obviously what's wrong

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by SiDi

Attachment: TextColor.png added

Screenshot that shows the bug.

comment:1 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

FileZilla does not set any colors for GUI components by itself, it uses the default colors as provided by wxWidgets, which in turn gets these colors from GTK itself.

I tried several darker themes on Ubuntu 8.10 beta and could not reproduce the problem. (Other the fact that all dark themes look terrible in general, but that's a different issue).

You might want to try 8.10 beta.

Some remark: Writing a good GTK engine is a complex job. I once looked into the clearlooks engine for a different rendering issue (listctrl headers in wxWidgets were looking odd). Clearlooks is very complex and makes several assumptions about the way controls are used and such. Things can easily break if using a drastically different theme (e.g. a dark one) with neither the theme (murrine) nor the application subject to it (filezilla) at fault.
In addition, you can at least partially blame evolution (or alternatively any non-empty set of gods if you prefer) for our imprecise visual perception capabilities. Medium-grey tex on light-great to white is easier to read than medium grey on dark grey to black background.

comment:2 Changed 11 years ago by SiDi

Hello,

I know Filezilla uses colors that come from GTK, what i'm pointing out is that the colors in GTK themes are separated in 4 groups (text areas, selected data, notifications, windows), and that Filezilla uses the textarea background for these explorers, but also seems to use the windows text colour instead of textarea text colours.

I'm joining a screenshot at which it may be more obvious to see what's wrong. Is there any way that you tell me in which part of the sources i should look at if i want to correct this by myself, either?

Thanks in advance.

Changed 11 years ago by SiDi

Attachment: Capture.jpg added

Screenshot that shows even more obviously what's wrong

comment:3 Changed 11 years ago by Tim Kosse

Get the wxWidgets sources and have a look at the following files:

  • src/generic/listctrl.cpp
  • src/gtk/window.cpp
  • src/common/wincmn.cpp
  • src/gtk/dc*.cpp
  • src/common/dc*.cpp

You might also grep for uses of wxSYS_COLOUR_*

Note: See TracTickets for help on using tickets.