Opened 11 years ago

Closed 11 years ago

#3826 closed Bug report (fixed)

queue size ignores number format

Reported by: Mats Owned by:
Priority: normal Component: FileZilla Client
Keywords: status line Cc: ci-dev@…
Component version: Operating system type:
Operating system version:

Description

Queue displays "MB" as "MiB" in lower right status line

Attachments (1)

fz.tif (63.4 KB) - added by Mats 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by Mats

Attachment: fz.tif added

comment:1 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

comment:2 Changed 11 years ago by Alexander Schuch

Cc: ci-dev@… added
Operating system type: Windows
Operating system version: XP
Resolution: rejected
Status: closedreopened
Summary: "MiB" lower right status linequeue size ignores number format

The status bar queue size item always formats the size using "IEC binary prefixes" regardless of what is configures as "Size formatting" in the settings.

comment:3 Changed 11 years ago by Tim Kosse

Resolution: fixed
Status: reopenedclosed

The latest version does honor the different prefixes as given in the settings dialog.

Note that it is by design that the queue size is never in bytes. Queues can be really huge, well into the terabyte range. At such sizes, the least significant digits are totally unimportant and an unabbreviated size would be unreadable.

Note: See TracTickets for help on using tickets.