Opened 11 years ago

Last modified 6 years ago

#3508 closed Bug report

transfer error possibly related with 'special' filenames

Reported by: matti3 Owned by:
Priority: normal Component: Other
Keywords: Cc: matti3, Alexander Schuch, Tim Kosse, marguskohv
Component version: Operating system type:
Operating system version:

Description

I transfered approximately 1000 files of which 24 failed. I have enabled debug output and requeued one file. see attachment for output.

Filezilla complains "file not found". I checked: the file certainly does exist. it contains special chars like (,),-

Attachments (1)

ftplog.txt (3.1 KB) - added by matti3 11 years ago.
debug output

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by matti3

Attachment: ftplog.txt added

debug output

comment:1 Changed 11 years ago by Alexander Schuch

Which version of FileZilla are you using?

comment:2 Changed 11 years ago by Alexander Schuch

Do other FTP clients work? This might be a bug with your FTP server. I right now tested with FileZilla SVN 2365 on Pure-FTPd and it works for me:

Command: PORT 127,0,0,22,193,231
Response: 200 PORT command successful
Command: RETR - text(fake).txt
Response: 150 Connecting to port 49639
Response: 226-File successfully transferred
Response: 226 0.000 seconds (measured here), 23.98 Kbytes per second

comment:3 Changed 11 years ago by matti3

version I use is 3.0.10. My directory name also contained ! but I guess that doesn't influence the file transfer itself..

I also tried with the old filezilla (2.x) and the behavior was the same. Also upgraded server (filezilla server) to latest version, no success. I will try with the windows command line ftp client and report back

comment:4 Changed 11 years ago by Alexander Schuch

Right now I tried FileZilla 3.0.10 on Microsoft Windows Server 2003 Web Edition 32bit and uploading the file "hey-(test).txt" into a directory called "sdf-!" worked fine.

Waiting for your tests of other FTP clients with same FTP server...

comment:5 Changed 11 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:6 Changed 11 years ago by matti3

Hi, I tested with the same ftp server and the command line windows ftp client. You are right. It is not a client problem, but a server problem. Should I issue a new bug against FileZilla Server, or can you simply change the category for this bug?

thanks

comment:7 Changed 11 years ago by matti3

sorry if I messed up the bug status

comment:8 Changed 11 years ago by Tim Kosse

Does the file you want to transfer have leading or trailing spaces?

comment:9 Changed 11 years ago by matti3

affirmative. 1 leading space.

comment:10 Changed 11 years ago by Alexander Schuch

@codesquid:
Bug in FileZilla Server and not the one mentioned in the following item?
[ 1564695 ] Problems with leading or terminating spaces

comment:11 Changed 11 years ago by marguskohv

FileZilla 3.0.11. ProFTPD 1.2.5rc1 Server (Debian).

I am also having problems downloading files with special characters. Example "Liste für Domino kompatible Produkte.pdf". If I rename ü->u it downloads just great.

OH... I just discovered, when I download these files one by one, then it works, but if I want do download multiple files it fails !

comment:12 Changed 11 years ago by Tim Kosse

To marguskohv: Do not post totally unrelated problems in existing bug reports. That is called thread hijacking and a very impolite thing to do.

comment:13 Changed 11 years ago by Tim Kosse

Note: See TracTickets for help on using tickets.