Opened 11 years ago

Last modified 11 years ago

#3418 closed Bug report

Linux configure issue for Filezilla 3.0.7.1

Reported by: buzzthebuzzsaw Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: buzzthebuzzsaw, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Hi All,

The --prefix option for configure seems to be ignored when searching for idna.h, I have most programs installed in a non standard location as I do not have root access so I point prefix to the base location for my installs. This usually works, but not for Filezilla, to work around this I did the following:

I created an sh script and set a variable pointing to where I wished prefix to point to and then used the following:

CPPFLAGS="-I/usr/include -I/usr/X11R6/include -I$PREFIX/include"
export CPPFLAGS
LDFLAGS="-L/lib64 -L/usr/lib64 -L/usr/X11R6/lib64 -L$PREFIX/lib"
export LDFLAGS

configure --prefix=$PREFIX

This allowed configure to complete.
I had tried setting --includedir and --libdir, but neither of these worked.

Can this be fixed so all that needs to be set it the prefix location?

Change History (1)

comment:1 Changed 11 years ago by Tim Kosse

The prefix is just for where the binaries should be installed, the lookup works differently.

idna.h is checked for using the standard AC_CHECK_HEADER macro, so obviously you need to set proper preprocessor flags if idna.h is outside the standard search path of your compiler.

Note: See TracTickets for help on using tickets.