Opened 12 years ago

Last modified 6 years ago

#3417 closed Bug report

data transferred incorrectly

Reported by: jmberthier Owned by:
Priority: normal Component: Other
Keywords: Cc: jmberthier, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

I ran into a problem using FileZilla:
I upload a DotClear blog on a site and everything went fine, apparently (tried with different providers).
When I try to run the install php file, it always fail to run (file not found error).
I use WsFTP to do the same task, everything went fine.
I tried different settings with no success.

To reproduce the problem :
-download the dotclear package (from www.dotclear.net)
-unpack on local drive.
-upload to a web site (www.mysite.com/dotclear/) using FileZilla.
-try to run the install script:
www.mysite.com/dotclear/install/index.php
(script error line 33)
-upload again with another ftp client (WSFTP)
-run the install script, and the install page loads up.

I cannot figure out what is wrong because when I check the files uploaded, eveything looks OK.

Attachments (1)

FileZilla-Dotclear_upload.txt (44.7 KB) - added by jmberthier 12 years ago.
Log level 3

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by Tim Kosse

Your configuration seems to be improper. Please run the network
configuration wizard and follow its instructions.

As long as the test at the end of the wizard fails, your
configuration is not correct.

Reopen only if the test succeeds and the problem did not go away.

comment:2 Changed 12 years ago by jmberthier

Result of configuration wizard :
Connexion sur probe.filezilla-project.org
Réponse : 220 FZ router and firewall tester ready
USER FileZilla
Réponse : 331 Give any password.
PASS 3.0.7.1
Réponse : 230 logged on.
Validation de l'adresse IP externe
IP 81.65.82.65 ib-gf-ic-gf
Réponse : 200 OK
PREP 58990
Réponse : 200 Using port 58990, data token 2037546357
PORT 81,65,82,65,230,110
Réponse : 200 PORT command successful
LIST
Réponse : 150 opening data connection
Réponse : 200 Successful
QUIT
Réponse : 200 goodbye!
Connexion fermée

This did not change the problem !

comment:3 Changed 12 years ago by Tim Kosse

Please attach some logs showing the problematic behaviour.

The logs should be made using debug level 3 which can be enabled
on the debug page in the settings dialog of FileZilla.

The logs have to be complete and unmodified. Do not attempt to
remove or obfuscate any information you might find irrelevant.

If you are worried about posting IP addresses or other
confidential information, mark the tracker item as private.

Changed 12 years ago by jmberthier

Log level 3

comment:4 Changed 12 years ago by jmberthier

Here is the log (level 3) for the upload.
It does not seem to show anything to me.
Maybe another approach will be to reproduce the step by step I describe in my orignal post
(Dotclear folder is a little bit less than 1 MB).
Thank you!
File Added: FileZilla-Dotclear_upload.txt

comment:5 Changed 12 years ago by Tim Kosse

Check the used transfer mode, should be set to Auto.
Also try transferring everything in ASCII mode as well as everything in Binary mode for a test.

comment:6 Changed 12 years ago by jmberthier

Already did that.
(and also tried to force iso-8859-1 for file names)...
I spent all day yesterday playing around with options, all end up to same result.
Only solution I found is to use another FTP client.

comment:7 Changed 12 years ago by Tim Kosse

Need to know what type of corruption. Upload the files, download them again into a different directory and use a tool like WinMerge to check for differences.

comment:8 Changed 12 years ago by jmberthier

Ok, I will try to do that in the next days.
May I suggest that, if you simply started by taking a few minutes to try to reproduce the case with the step by step I produced in my initial post, instead of getting into this zillions messages exchange, there would have been much time and energy saved.
Case 1 : the problem happens on your machine, and you have all the elements at your hand to try to figure out why.
Case 2 : You cannot reproduce the problem. Then you can close the report, and think of something else.
Regards.

comment:9 Changed 12 years ago by jmberthier

Sorry, my mistake!
I am closing with apologies.
(I forgot that a file filter was active!)

Note: See TracTickets for help on using tickets.