Opened 12 years ago

Last modified 6 years ago

#3398 closed Bug report

Unable to establish TLS v1.0 secured connection

Reported by: sdfdl Owned by:
Priority: normal Component: Other
Keywords: Cc: sdfdl, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Good afternoon.
I was using the previous version 2.2.32. to connect a bank to download relevant informations.
A few weeks ago I tried the version 3.0.5.2 and now the 3.0.6.
It seems I am not able to connect anymore to the relevant server.
I have to connect using port 10021 passive mode explicitSSL.

I attach the trace file made with firstly the version 2 and secondly with version 3.0.6.
Someone on the forum tried to explain me the problem and suggested I report it as a bug !

Here is his explaination :
The changes for Filezilla Client version 3.0.4.1 note the use of a new version of GnuTLS (2.0.4). Starting with this version you may encounter problems with secure file tansfers. Previous to this version, Filezilla client would send a TLS v1.0 ClientHello as part of the SSL/TLS handshake. This version (3.1) of the protocol is widely deployed. If the server agreed to this version, or even chose earlier version 3.0 (SSL) the handshake continued to completion. With versions starting with 3.0.4.1, the Filezilla client send a TLS v1.1 ClientHello (not widely deployed), and if the server does not send a ServerHello with this version, the handshake is terminated. In effect, Filezilla client will now only be able to talk to servers supporting the TLS v1.1 protocol. I would be surprised if this was the developer's intent. You should write a bug report for this.

I hope it could help.
Best REGARDS
S

Attachments (1)

trace.txt (5.9 KB) - added by sdfdl 12 years ago.
trace of the 2 attempts

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by sdfdl

Attachment: trace.txt added

trace of the 2 attempts

comment:1 Changed 12 years ago by Tim Kosse

Can you provide me with a test account on your server? If I cannot reproduce this problem I cannot fix it.

comment:2 Changed 12 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.