Opened 13 years ago

Last modified 6 years ago

#3161 closed Bug report

Cannot run from some directories

Reported by: crackpl Owned by:
Priority: normal Component: Other
Keywords: Cc: crackpl, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

FileZilla betas cannot be run from a directory containing the "#" character in its name (eg. c:\#filezilla). It runs fine when I run it from c:\filezilla.

Steps to reproduce:
Copy FileZilla 3.0.0 beta 10 (or any earlier) to c:\#filezilla and run filezilla.exe

Log:
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/AUTOEXEC.BAT'.
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/CONFIG.SYS'.
17:37:18: XML parsing error: 'not well-formed (invalid token)' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/log.txt'.
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/AUTOEXEC.BAT'.
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/CONFIG.SYS'.
17:37:18: XML parsing error: 'not well-formed (invalid token)' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/log.txt'.
17:37:18: XRC resource 'ID_MENUBAR' (class 'wxMenuBar') not found!
17:37:18: Cannot load main menu from resource file
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/AUTOEXEC.BAT'.
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/CONFIG.SYS'.
17:37:18: XML parsing error: 'not well-formed (invalid token)' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/log.txt'.
17:37:18: XRC resource 'ID_MENU_DEBUG' (class 'wxMenu') not found!
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/AUTOEXEC.BAT'.
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/CONFIG.SYS'.
17:37:18: XML parsing error: 'not well-formed (invalid token)' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/log.txt'.
17:37:18: XRC resource 'ID_TOOLBAR' (class 'wxToolBar') not found!
17:37:18: Cannot load toolbar from resource file
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/AUTOEXEC.BAT'.
17:37:18: XML parsing error: 'no element found' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/CONFIG.SYS'.
17:37:18: XML parsing error: 'not well-formed (invalid token)' at line 1
17:37:18: Cannot load resources from file 'file:/C%3A/log.txt'.
17:37:18: XRC resource 'ID_QUICKCONNECTBAR' (class 'wxPanel') not found!
17:37:18: Cannot load Quickconnect bar from resource file

Change History (4)

comment:1 Changed 13 years ago by Tim Kosse

This is a limitation of wxWidgets, it's filesystem abstraction layer cannot handle filenames containing a #

comment:2 Changed 13 years ago by crackpl

Then can you at least add a more descriptive error message?

comment:3 Changed 12 years ago by Tim Kosse

Problem has been fixed in wxWidgets CVS. Please try the 2007-06-22 nightly build of FZ3 from http://filezilla-project.org/nightly.php tomorrow.

comment:4 Changed 12 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.