Opened 16 years ago

Last modified 6 years ago

#306 closed Bug report

SFTP using SSH2 not working in Win9x

Reported by: gboutwel Owned by:
Priority: normal Component: Other
Keywords: Cc: gboutwel, adhisimon, snol
Component version: Operating system type:
Operating system version:

Description

My father & co-workers had reported problems with Win9x
(98 SE & ME) connecting to my SFTP server. I use Win2k
(at home) & XP (at work) and didn't have any problems
with FileZilla connecting.

I now have an Windows 98SE laptop that I'm experiencing
the same problem my father & co-worker had.

Steps to reproduce the problem on Win98SE:

1) Install FileZilla
2) Choose 'secure' mode - where it doesn't keep passwords
3) Choose XML, not registry for settings.
4) Run program
5) Open site manager, add site, choosing type of SFTP
using SSH2
6) Attempt a connect, entering password when prompted
for it.

Results of the above:

COMMAND: CONNECT server:22, initializing SFTP connection...
FzSFtp.exe did not respon, terminating connection...

which repeats over and over until the timeout/retries
are reached.

I have tried v2.1.4, 2.1.5, and now 2.1.6a on this
machien and they all result in the same.

I'm will to assist with the resolution of this bug as
much as possible. I even have MS VC 6 on this laptop,
& have installed v2.1.6a w/source

Attachments (2)

FzSFtp Failure On Win9x.txt (1.6 KB) - added by gboutwel 16 years ago.
Log from FileZilla for this problem
FzSFtp Failure On Win9x Trace.txt (6.1 KB) - added by gboutwel 16 years ago.
FzSFTP failing on Win9x with ftp engine traces

Download all attachments as: .zip

Change History (6)

Changed 16 years ago by gboutwel

Attachment: FzSFtp Failure On Win9x.txt added

Log from FileZilla for this problem

Changed 16 years ago by gboutwel

FzSFTP failing on Win9x with ftp engine traces

comment:1 Changed 16 years ago by adhisimon

it's not just happen if you choose XML. if you choose registry for
settings it happens to me too.

comment:2 Changed 16 years ago by anonymous

Logged In: NO

It happened to me as well :-(. What to do? ;-)

comment:3 Changed 15 years ago by snol

I get the same thing; this is the output if I enable all the
debug options. This is on win98SE, filezilla client 2.2.5a:

Command: CONNECT user@server:22
Trace: FzSFtp.exe:
cvsroot\FileZilla\source\FzSFtp\SSH.C(1949): Server version:
SSH-1.99-OpenSSH_3.7.1p2
Trace: FzSFtp.exe:
cvsroot\FileZilla\source\FzSFtp\SSH.C(1985): We claim
version: SSH-2.0-PuTTY-FZ-Local: Dec 7 2003 23:38:26
Trace: FzSFtp.exe:
cvsroot\FileZilla\source\FzSFtp\SSH.C(1987): Using SSH
protocol version 2
Trace: SftpControlSocket.cpp(2465): OnReceive(0)
caller=0x00fb3df0
Trace: FzSFtp.exe:
cvsroot\FileZilla\source\FzSFtp\SSH.C(4216): Doing
Diffie-Hellman group exchange
Trace: SftpControlSocket.cpp(2465): OnReceive(0)
caller=0x00fb3df0
Error: FzSFtp.exe did not respond, terminating connection.
Trace: SftpControlSocket.cpp(2271): DoClose(0)
caller=0x00fb3df0
Trace: SftpControlSocket.cpp(2301): ResetOperation(4100)
caller=0x00fb3df0
Error: Unable to connect!

comment:4 Changed 15 years ago by gboutwel

I'm the original poster of the this bug. I stil have the laptop
in the original bug post. I found a work around which seems
to have solved the problem. I'll do my best to detail it, here.

As result of the work-around I'm marking this bug closed (if

it'll let me).

Steps for Work around:

1) Load PuTTY
2) Load Default Setting of PuTTY.
3) Go to the Bugs setting under SSH
4) Under Bug settings an setting for working around broken

servers. The one labeled 'Chokes on Diffe-Hellman group
exchange' should be changed to On instead of the default of
Auto.

5) Save this setting as the Default Setting of PuTTY.

Try connecting to the server that you where having problem
with before and it should just work.

Enjoy

Note: See TracTickets for help on using tickets.