Opened 14 years ago

Last modified 6 years ago

#3028 closed Bug report

SFTP to VMS server doesn't work

Reported by: yeshua Owned by: Alexander Schuch
Priority: normal Component: Other
Keywords: Cc: yeshua, Alexander Schuch, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

When I SFTP to a VMS server, all directories show up as
empty.

Trace logs indicate that OpenVMS's SFTP server lists
directory contents as bare filenames, e.g.:
Trace: JTEST.DSC;1
Trace: JTEST.DTA;1
Trace: JTEST.RMS$JOURNAL;2

FTP works.

Change History (10)

comment:1 Changed 13 years ago by Alexander Schuch

Can you please try FileZilla 3 beta and check if the problem still happens for you?

comment:2 Changed 13 years ago by yeshua

I tested FileZilla 3.0.0 beta 2.

With Servertype set to Default, behavior seems to be similar
to the previous version. I.e., the following shows up in
debug logs but no directory contents are listed:
Listing: TEST.COM;44
Listing: TEST.PL;29
Listing: TEST.PL;29
Listing: test.txt;2
Listing: test.txt;2

With Servertype set to VMS, I get the following in the debug
logs:
Status: Retrieving directory listing...
Command: pwd
Response: Current directory is: "/users/jkelley"
Trace: ControlSocket.cpp(529): Can't parse path
caller=00F548D8
Trace: CSftpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Trace: CSftpControlSocket::SendNextCommand(2)
Trace: CSftpControlSocket::ListSend(2)
Trace: CSftpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Error: Failed to retrieve directory listing

Thanks.

comment:3 Changed 13 years ago by Tim Kosse

I don't think I can add support for this particular server.
It uses a unix style path format, yet sends listings in a
format that contains too few information, it would break
parsing other formats.

comment:4 Changed 13 years ago by yeshua

This is an OpenVMS server running HP TCP/IP Services for
OpenVMS, so it ought to be a pretty common setup. (Common
for VMS, at least.)

Would it work to only parse this style of listing for SFTP
connections when Servertype is VMS? (VMS servers over FTP
connections shows the VMS style path format, but from what
I've seen, VMS servers over SFTP connections use the Unix
style path format.)

comment:5 Changed 13 years ago by Tim Kosse

Unfortunately it would break compatibility especially
towards other VMS servers which use multiline listings.

comment:6 Changed 13 years ago by yeshua

Do you have any details on VMS setups that use multiline
listings?

Sorry to be a pain about this, but I'm frustrated that I
haven't been able to find a good graphical SFTP client for
our VMS server, so if nothing else I'd like to play around
with the problem on my own time.

comment:7 Changed 13 years ago by Tim Kosse

All I know is that there are servers that wrap the listing entries and that different servers wrap at different columns.

comment:8 Changed 13 years ago by Tim Kosse

Please try tomorrow's (2006-12-07) nightly once it got built.

comment:9 Changed 13 years ago by yeshua

Sorry, I just now got around to trying beta 4.

It works now. Thank you very much for your help. More details:

Servertype default works but servertype VMS does not. (Similar to before.)

I am noticing a different problem now (which I can log as a separate bug if you wish): Trying to download a larger zip file from the OpenVMS server fails. The client downloads 128KB, then pauses, then reports connection timed out and restarts the connection. After restarting the connection, it starts the download, then reports "Error: Out of memory!", then immediately restarts the download with the same result, in an endless loop. This may be a problem with the server rather than with FileZilla: once, while trying to download the same file with SFTP, I got an error "Received message too long 4174318280". If it is a server bug, then FileZilla is somehow triggering it every time instead of just once.

Thanks again for your help.

comment:10 Changed 13 years ago by Tim Kosse

FileZilla's SFTP support is based on PuTTY. Can you download the file using http://www.tartarus.org/~simon/putty-snapshots/x86/psftp.exe ?

If that fails too, it's either a bug in PuTTY or a server problem.

Note: See TracTickets for help on using tickets.