Opened 12 years ago

Closed 2 years ago

#2884 closed Feature request (duplicate)

Disable Account after the "Expiration Date"

Reported by: charlothuang Owned by:
Priority: high Component: FileZilla Server
Keywords: expiration, account, user Cc: charlothuang, russ@…
Component version: Operating system type: Windows
Operating system version:

Description

Users -> General

Account settings

-- Enable account

-- Expiration Date

A feature that accounts can be disabled after the "Expiration Date" set.

Thanks a lot ~

Change History (6)

comment:1 Changed 11 years ago by roeme

Keywords: expiration account user added

This is feature which I am seeking for as well. Given some minor assistance by the developers, I would even submit a patch for that. I'll just need to know if there is periodically executed code and where it resides.

comment:2 Changed 7 years ago by dw5304

Priority: normalblocker

5 years and nothing has come of this feature?
also wanting this.

comment:3 Changed 6 years ago by Russ

Cc: russ@… added
Operating system type: Windows
Priority: blockerhigh

please add this feature

comment:4 Changed 2 years ago by Kurt McKee

Triage suggestion

This feature does not appear to be available FileZilla Server 0.9.60. However, this feature request is nine years old.

If there are no plans to implement automatic account expiration, I suggest closing this feature request.

Note: The FileZilla Server configuration is stored in an XML document and it would be possible to write an external program to implement this:

  1. When creating a user, add a line like Expires: 2017-05-07 in the description.
  2. Write a piece of software that parses the XML file for users that contain the Expires: text in the description.

If the expiration date is after the specified date, change the text of the user's <Option Name="Enabled"> XML element to 0.

  1. Add a scheduled event that runs your software once a day and restarts FileZilla Server using this command:

C:\Program Files (x86)\FileZilla Server\FileZilla server.exe /reload-config

comment:5 Changed 2 years ago by Kurt McKee

This is a duplicate of #2338

comment:6 Changed 2 years ago by Kurt McKee

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.