Opened 11 years ago

Last modified 11 years ago

#1420 closed Bug report

Vista specific settings export failure

Reported by: cedial Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: cedial, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Exporting of settings save dialog does not report a save failure under Vista. Filezilla indicates the save succeeded when it did not. This is NOT a problem with XP or Win 2000.

The problem occurs when saving into a folder such as Program Files that requires administrator priveleges for writing a file. The Vista privelege escalation dialog goes smoothly and correctly, but the user's authorization to proceed is mishandled by Filezilla and no indication is given that the save failed.

The attached screen dump shows that filezilla3a.xml existed when it didn't. It continued to not exist even after the apparently flawless save "completed".

NOTE: Exporting the settings to the Documents folder of course works, and dragging the resultant file from Documents to the access restricted Filezilla Client directory works.

Attachments (1)

Filezilla Export Failure.png (122.5 KB) - added by cedial 11 years ago.
screen dump showing that filezilla3a.xml exists when it doesn't.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by cedial

screen dump showing that filezilla3a.xml exists when it doesn't.

comment:1 Changed 11 years ago by Tim Kosse

Check %LOCALAPPDATA%\VirtualStore

It's not a bug in FileZilla, it's a huge intentional bug in Vista.

Note: See TracTickets for help on using tickets.