Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#12984 closed Bug report (rejected)

Directory listing problem with using minio ftp

Reported by: Birkan Owned by:
Priority: normal Component: FileZilla Client
Keywords: minio, folder, listing Cc: Birkan
Component version: 3.65 Operating system type: Windows
Operating system version: Windows 10 Pro 22H2

Description (last modified by Birkan)

Hello,

We are using minio cluster and activated ftp feature. Then we tried to connect with filezilla on a windows machine. It is connecting successfully, and listing buckets fine. But when we tried to get in a bucket, we can't see folders.

PS: When we use MacoS everything is fine. On windows , when we try winscp, it is listing successfully. Only filezilla can't.

Attachments (1)

filezilla_bug.png (85.1 KB ) - added by Birkan 8 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 by Birkan, 8 months ago

Description: modified (diff)

comment:2 by Birkan, 8 months ago

Priority: highblocker

comment:3 by Tim Kosse, 8 months ago

Priority: blockernormal

comment:4 by Tim Kosse, 8 months ago

Status: newmoreinfo

Please enable "Show raw directory listings" in the settings dialog of FileZilla, then connect to the server and submit a complete log of a listing attempt.

comment:5 by Birkan, 8 months ago

Status: moreinfonew

Hello, here is ;

Status: Directory listing of "/" successful
Status: Retrieving directory listing of "/ayyapim"...
Command: CWD ayyapim
Response: 250 Directory changed to /ayyapim
Command: PWD
Response: 257 "/ayyapim" is the current directory
Command: PASV
Response: 227 Entering Passive Mode (185,241,63,44,123,46)
Command: MLSD
Response: 150 Opening ASCII mode data connection for file list
Listing: Type=dir;Modify=00010101000000;Size=0; .Spotlight-V100
Listing: Type=dir;Modify=00010101000000;Size=0; 20 DAKIKA
Listing: Type=dir;Modify=00010101000000;Size=0; BANA_SEVMEYI_ANLAT
Listing: Type=dir;Modify=00010101000000;Size=0; BU_SEHIR_ARKANDAN_GELECEK
Listing: Type=dir;Modify=00010101000000;Size=0; CUKUR
Listing: Type=dir;Modify=00010101000000;Size=0; EZEL
Listing: Type=dir;Modify=00010101000000;Size=0; ICERDE
Listing: Type=dir;Modify=00010101000000;Size=0; KARADAYI
Listing: Type=dir;Modify=00010101000000;Size=0; KARA_PARA_ASK
Listing: Type=dir;Modify=00010101000000;Size=0; KARA_SEVDA
Listing: Type=dir;Modify=00010101000000;Size=0; KIRMIZI-KAMYON
Listing: Type=dir;Modify=00010101000000;Size=0; KURT_SEYT_SURA
Listing: Type=dir;Modify=00010101000000;Size=0; KUZEY_GUNEY
Listing: Type=dir;Modify=00010101000000;Size=0; MEDCEZIR
Listing: Type=dir;Modify=00010101000000;Size=0; ZEMHERI
Listing: Type=dir;Modify=00010101000000;Size=0; yargi
Response: 226 Closing data connection, sent 812 bytes
Status: Directory listing of "/ayyapim" successful

by Birkan, 8 months ago

Attachment: filezilla_bug.png added

comment:6 by Tim Kosse, 8 months ago

Resolution: rejected
Status: newclosed

Modify=00010101000000

The server claims the directories were last modified on January 1st in the year 1 AD.

Please contact your server vendor for further assistance, so that the server can be fixed to either report a reasonable modification date, or simply omit it if there truly is no modification date for a given entry.

PS: When we use MacoS everything is fine. On windows , when we try winscp, it is listing successfully. Only filezilla can't.

Different operating systems and runtime libraries have different capabilities when it comes to processing timestamps that either predate digital computers or are far into the future.

comment:7 by Birkan, 8 months ago

Hello again,

I received an answer from MinIO.

can you try to read from any sdk for example ( minio-py, minio-go, aws-sdk) ? if they all have same results.. you could go back to the ticket..

We tried these sdks and saw that folder's modification date is coming true. Which side has problem i don't know. How can you help me?

Thank you

comment:8 by Tim Kosse, 8 months ago

They gave a very strange answer, do they not understand their own product?

What is shown in the raw directory listing is coming straight from the server. Which makes it pretty clear which side is having the problem.

comment:9 by Birkan, 8 months ago

Hello again,

I have new answers from MinIO,

-There is no concept of Folder in object storage.
it is just a way to organise. prefix. https://docs.aws.amazon.com/AmazonS3/latest/userguide/using-prefixes.html

if you are looking for "Folders" (prefix) , No, the dates will not be returned
https://docs.aws.amazon.com/AmazonS3/latest/API/API_ListObjects.html

Note: See TracTickets for help on using tickets.