Opened 13 months ago

Closed 10 months ago

Last modified 10 months ago

#12900 closed Bug report (worksforme)

Error saving/loading queue

Reported by: DXL3969 Owned by:
Priority: normal Component: FileZilla Client
Keywords: error saving loading transfer queue sqlite3 Cc:
Component version: 3.63.2.1 Operating system type: Windows
Operating system version: Windows 11 Home

Description

I just updated my FileZilla client for the first time in a while (via the prompt on startup), and after that it started giving me an error message every time it started or closed the program. The error on starting was:

An error occurred loading the transfer queue from
"C:\Users\myusername\AppData\Roaming\FileZilla\queue.sqlite3".
Some queue items might not have been restored.

The error on closing was almost identical:

An error occurred saving the transfer queue to
"C:\Users\myusername\AppData\Roaming\FileZilla\queue.sqlite3".
Some queue items might not have been saved.

Additional information:

  • The program is installed to a different drive than the folder it is trying to write to. It is located at "E:\Program Files\FileZilla FTP Client" and the folder it is trying to write to is on the C drive (listed above). Not sure if this is relevant or not, but you said to be verbose.
  • The file did exist in the location the program was looking, and the previous version of the client could read and write to it just fine.
  • The error messages stopped showing up when I deleted queue.sqlite3 and let the program regenerate the file, although I have kept the old queue.sqlite3 just in case. This means that the issue is solved for me, but I figured you might still want to know that this file isn't always compatible if you forget to update for a while and then go up by a couple versions at once.

Attachments (2)

Screenshot 2023-07-12 at 9.48.22 AM.png (56.0 KB ) - added by brandsteve 10 months ago.
Screenshot 2023-07-12 at 9.48.47 AM.png (55.6 KB ) - added by brandsteve 10 months ago.

Download all attachments as: .zip

Change History (6)

comment:1 by shipscript, 13 months ago

Just updated to 3.63.2.1 on Win 10 running on Parallels on a Mac OS 11.6.4.
Older version was ~3.58, I think.

Updated while the prior FileZilla client was open, but don't recall if the app automatically closed when installation began (used the non-sponsored installer).

Restarting the updated client, or closing the client, provoked the same set of "queue" error messages as posted here. I did not try to upload/transfer anything, except to read the server directories of various servers, and opened and closed the app many times before looking for help.

To successfully eliminate the error messages, I renamed the "queue.sqlite3" target file and allowed FileZilla to recreate a new file, as suggested here.

comment:2 by brandsteve, 10 months ago

Get the same error with the MacOS app installed from the MacOS store

FileZilla Pro


Version: 3.64.0

Build information:

Compiled for: x86_64-apple-darwin22.4.0
Compiled on: x86_64-apple-darwin22.4.0
Build date: 2023-05-03
Compiled with: Apple clang version 14.0.3 (clang-1403.0.22.14.1)
Compiler flags: -O2 -g -Wall -Wextra -pedantic -O2 -g -Wall -Wextra -pedantic -mmacosx-version-min=10.13.0 -Werror=partial-availability

Linked against:

wxWidgets: 3.2.1
SQLite: 3.39.4
GnuTLS: 3.8.0

Operating system:

Name: macOS Ventura Version 13.4.1 (a) (Build 22F770820b)
Version: 13.4
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx avx2 aes pclmulqdq rdrnd bmi bmi2 adx lm
Settings dir: ~/Library/Containers/org.filezilla-project.filezilla.sandbox/Data/.config/filezilla/

comment:3 by Tim Kosse, 10 months ago

Resolution: worksforme
Status: newclosed

The file in question got damaged somehow, most likely due to an unclean system shutdown.

If you don't mind losing any data remaining in the file, you can safely delete it and a new file will be created automatically.

comment:4 by brandsteve, 10 months ago

That solved it for me. Can't speak for the creator of the ticket.

Note: See TracTickets for help on using tickets.