Opened 14 months ago

#12899 new Bug report

FileZilla fails to open Visual Studio Code

Reported by: hanshenrik Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: hanshenrik
Component version: 3.63.2.1 Operating system type: Windows
Operating system version: Windows 10 22H2 (OS Build 19045.2728)

Description

Could have sworn this worked in older versions of FileZilla, but it does not work now:

Installing Visual Studio Code and setting the following file association in FileZilla -> edit -> Settings -> File Editing -> Filetype associations:
php "C:\Program Files\Microsoft VS Code\Code.exe" --add "%f"

then trying to edit a .php file from FileZilla with right-clicking on a PHP file and clicking "View/Edit"

will result in... nothing. VSCode is not started. (as far as i can see, FileZilla does not attempt to start code.exe at all)

Pretty sure this worked in older versions of FileZilla.

observed on:
FileZilla Client


Version: 3.63.2.1

Build information:

Compiled for: x86_64-w64-mingw32
Compiled on: x86_64-pc-linux-gnu
Build date: 2023-03-03
Compiled with: x86_64-w64-mingw32-gcc (GCC) 10-win32 20210110
Compiler flags: -O2 -g -Wall -Wextra -Wno-deprecated-copy -ffunction-sections -fdata-sections -Wno-cast-function-type

Linked against:

wxWidgets: 3.2.1
SQLite: 3.39.4
GnuTLS: 3.8.0

Operating system:

Name: Windows 10 (build 19045), 64-bit edition
Version: 10.0
Platform: 64-bit system
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx avx2 aes pclmulqdq rdrnd bmi bmi2 adx lm
Settings dir: C:\Users\hans\AppData\Roaming\FileZilla\

Change History (0)

Note: See TracTickets for help on using tickets.