Opened 3 months ago

Closed 3 months ago

#12780 closed Bug report (worksforme)

attempting to enter folder called "Alcohol 120%" causes program to lockup

Reported by: DarkRolder Owned by:
Priority: normal Component: FileZilla Client
Keywords: filename issue, Alcohol 120%, freeze, locking up Cc:
Component version: multiple including latest Operating system type: Windows
Operating system version: latest

Description

Hello, i am sumbitting this ticket i discovered a few years ago while browsing files on my server. i think the issue is the 20% specifically. but i havent done any specific testing. just thought i would let you know about this issue, that i am quite surprised hasnt been reported yet.

i have verfified if i remove the "%" from the folder name i have no problem entering the folder. its been a while since i was messing with is, but if i recall properly i created a folder with just "%" and that opened just fine but again probably should verify that.

Change History (4)

comment:1 by Tim Kosse, 3 months ago

Status: newmoreinfo

Which version of FileZilla are you using?

comment:2 by DarkRolder, 3 months ago

Status: moreinfonew

Hmm, i am at a loss. i just blindly created a folder named as above in the near same location as the original. and i am able to enter it without issue. yet for many times over the past few years, (not sure where to put this tidbit, i did this recent change about 2-3 weeks ago, where i couldn't enter and did testing) I was not able to enter this location ( i haven't really had a need) i just assumed it was due to the large number of files in the folder. but after another folder had 2000 items in it, i suspected something else, and removed the % symbol from the name and was able to enter it. i then created a folder with only a % and could enter that. i am not sure what the issue was. i am going to do further testing, removing the new folder i just created, and renaming the folder back to what it was originally called. will report back shortly.

FileZilla Client


Version: 3.60.2

Build information:

Compiled for: x86_64-w64-mingw32
Compiled on: x86_64-pc-linux-gnu
Build date: 2022-07-22
Compiled with: x86_64-w64-mingw32-gcc (GCC) 10-win32 20210110
Compiler flags: -O2 -g -Wall -Wextra -Wno-deprecated-copy -ffunction-sections -fdata-sections -Wno-cast-function-type

Linked against:

wxWidgets: 3.0.6
SQLite: 3.35.5
GnuTLS: 3.7.2

Operating system:

Name: Windows 10 (build 19043), 64-bit edition
Version: 10.0
Platform: 64-bit system
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx avx2 aes pclmulqdq rdrnd bmi bmi2 adx lm
Settings dir: C:\Users\somename\AppData\Roaming\FileZilla\

comment:3 by DarkRolder, 3 months ago

ok, still working, I do not know what has changed, it would appear though that I have wasted your time. I apologize for that.

comment:4 by Tim Kosse, 3 months ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.