Opened 11 months ago

Closed 9 months ago

#12621 closed Bug report (fixed)

Not able to access folder shared via Filezilla

Reported by: Healthvue Owned by: Tim Kosse
Priority: normal Component: FileZilla Server
Keywords: Cc:
Component version: 1.1.0 Operating system type: Windows
Operating system version: Windows 10

Description

We have shared some folder using FileZilla server to our client , so that they can have access to the folder. However, the client is getting an error(Screenshot attached).
Using latest filezilla version.

Attachments (6)

image+(4).png (20.5 KB ) - added by Healthvue 11 months ago.
image-20211027-135240 (1).png (1.0 MB ) - added by Healthvue 11 months ago.
log1.PNG (227.6 KB ) - added by Healthvue 11 months ago.
log2.PNG (253.9 KB ) - added by Healthvue 11 months ago.
mountPoint.PNG (122.5 KB ) - added by Healthvue 11 months ago.
Changedmount.PNG (113.5 KB ) - added by Healthvue 11 months ago.

Download all attachments as: .zip

Change History (24)

by Healthvue, 11 months ago

Attachment: image+(4).png added

by Healthvue, 11 months ago

comment:1 by Tim Kosse, 11 months ago

Status: newmoreinfo

What does it say in the server log?

comment:2 by Healthvue, 11 months ago

Status: moreinfonew

Added the logs in the attachment.

by Healthvue, 11 months ago

Attachment: log1.PNG added

by Healthvue, 11 months ago

Attachment: log2.PNG added

comment:3 by Tim Kosse, 11 months ago

Status: newmoreinfo

First log: Which mount points do you have configured in the server?

Second log: Which client are you using? Looks like it is outdated.

comment:4 by Healthvue, 11 months ago

Status: moreinfonew

Mount Point- Screenshot attached.
User(Test_VL) is using WinSCP to connect to this mount point.
For quicker resolution can we connect over a call.

by Healthvue, 11 months ago

Attachment: mountPoint.PNG added

comment:5 by Tim Kosse, 11 months ago

Resolution: worksforme
Status: newclosed

Please update the server to 1.2.0

According to log1.PNG you are attempting to list "/" but according to the mountPoint.PNG there is directory mounted at "/"

Make sure to access "/test_FTP" or add a mount under "/" if you don't want to configure the initial path in your client.

comment:6 by Healthvue, 11 months ago

As per the instruction mentioned given initial path as "/" ,attached in screenshot. But still facing the same issue as mentioned in pervious chats.

comment:7 by Healthvue, 11 months ago

Resolution: worksforme
Status: closedreopened

by Healthvue, 11 months ago

Attachment: Changedmount.PNG added

comment:8 by Tim Kosse, 11 months ago

Status: reopenedmoreinfo_reopened

Please update the server to 1.2.0

comment:9 by Healthvue, 11 months ago

Status: moreinfo_reopenedreopened

Updated FileZilla to 1.2.0 version.
For quicker resolution can we connect over a call.

comment:10 by Tim Kosse, 11 months ago

Status: reopenedmoreinfo_reopened

Calls are not archiveable and not searchable.

Does the Windows account the FileZilla Server service runs under, SYSTEM by default, have permission to access the target directory?

comment:11 by Healthvue, 11 months ago

Status: moreinfo_reopenedreopened

There are few users who are able to access the folders which they are permitted to access. But most of them are not able to.

We have all the permissions set to the SYSTEM account.

comment:12 by Marco Peroni, 10 months ago

I noticed a similar flaw which perhaps explains the problem: when I save the configuration Filezilla Server remove some "/" from the native PATH:
for example I write
10.10.0.126\ftp_dream\Dream\dreams\UPLOAD
but, when I apply it save
10.10.0.126\ftp_dreamDreamdreamsUPLOAD causing the same error reported here.. it could be an explanation, however it is a mistake to correct

comment:13 by Healthvue, 10 months ago

As commented by Marco Peroni, this issue exists for other users as well and might be a software bug. What is the workaround for this and a permanent solution for the same?

comment:14 by Healthvue, 10 months ago

Any information on the workaround for inaccessibility of folders and files shared via FileZilla?

comment:15 by Marco Peroni, 10 months ago

this is only a workaround: I opened the configuration file, corrected the path string adding the slashes mistakenly removed by the software bug and restarted the service... but this is only a temporary workaround because if you modify the configuration and save again you have to repeat the workaround. We hope that the developers will provide a patch to fix this flaw

comment:16 by Tim Kosse, 10 months ago

Owner: set to Tim Kosse
Status: reopenedaccepted

I've been able to reproduce this issue.

comment:17 by Healthvue, 10 months ago

Thank you Marco Peroni for following up. @Tim Kosse, can you please suggest a resolution to this issue as this is adversely affecting the production environment and performance?

comment:18 by Fabio Alemagna, 9 months ago

Resolution: fixed
Status: acceptedclosed

This should be a solved problem in 1.3.0. Closing this ticket. Please reopen if the problem still persists.

Note: See TracTickets for help on using tickets.