Opened 5 months ago

Closed 5 months ago

#12617 closed Bug report (fixed)

Server version 1.1.0 - 550 Couldn't open the file or directory

Reported by: Turbofiero Owned by: Fabio Alemagna
Priority: normal Component: FileZilla Server
Keywords: Server 1.1.0 Cc:
Component version: 1.1.0 Operating system type:
Operating system version: Windows Server 2019

Description (last modified by Turbofiero)

It seems as though updating from 1.0.1 to 1.1.0 has given me this bug

If I make a user, make a group for that user, then mount a drive as /group it will receive this error

The only way it works is if something in the group is mounted as "/"

Workaround seems to be to mount an empty folder as "/" then I can mount each folder

Is there something wrong with the way I'm doing things or is this a bug?

Change History (6)

comment:1 by Turbofiero, 5 months ago

Description: modified (diff)

comment:2 by Fabio Alemagna, 5 months ago

Could you check if this behavior exists also with the latest release? 1.2.0 has just been released: https://filezilla-project.org/download.php?type=server

comment:3 by Fabio Alemagna, 5 months ago

Status: newmoreinfo

comment:4 by Turbofiero, 5 months ago

Status: moreinfonew

Same behavior... any user I make requires something mounted as "/" in order to get the directory listing

comment:5 by Fabio Alemagna, 5 months ago

Owner: set to Fabio Alemagna
Status: newaccepted

Confirmed, it's a bug.

You can however still access the mountpoints you selected, they will however not be listed under '/'.

comment:6 by Fabio Alemagna, 5 months ago

Resolution: fixed
Status: acceptedclosed

The bug has been fixed. Please, test the next nightly build (from day December 27).

Note: See TracTickets for help on using tickets.