Opened 12 months ago

Closed 5 weeks ago

#12544 closed Bug report (fixed)

hard crash - Faulting module name: libstdc++-6.dll

Reported by: mark Owned by:
Priority: normal Component: FileZilla Server
Keywords: Cc:
Component version: 1.0.1 Operating system type: Windows
Operating system version: 2012 r2

Description

The filezilla logfile is empty, all i have is this in the windows eventlog:

Faulting application name: filezilla-server.exe, version: 0.0.0.0, time stamp: 0x00000000
Faulting module name: libstdc++-6.dll, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0x40000015
Fault offset: 0x000000000001f70a
Faulting process id: 0x5f8
Faulting application start time: 0x01d7b11f4c9119a6
Faulting application path: C:\Program Files\FileZilla Server\filezilla-server.exe
Faulting module path: C:\Program Files\FileZilla Server\libstdc++-6.dll
Report Id: e5e5db18-1fa7-11ec-8123-0026824f9497
Faulting package full name:
Faulting package-relative application ID:

Change History (13)

comment:1 by Tim Kosse, 12 months ago

Priority: blockernormal

Not a blocker, doesn't affect absolutely all users.

comment:2 by Markus, 2 months ago

I installed the newest version and now I have this problem also. FileZilla crashes around every 10 Minutes...

comment:3 by Tim Kosse, 2 months ago

Status: newmoreinfo

Please attach the latest crash dump located at %LOCALAPPDATA%\CrashDumps

comment:4 by Markus, 2 months ago

Status: moreinfonew

I'm sorry, but there are no crashdumps. FileZilla-server.exe ist registered for crashdumps but there are none...???

I have the following key in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps\filezilla-server.exe
With value (dword) DumpType = 1

I only see the error in the event log and the service is not running any more...

Name der fehlerhaften Anwendung: filezilla-server.exe, Version: 0.0.0.0, Zeitstempel: 0x00000000
Name des fehlerhaften Moduls: libstdc++-6.dll, Version: 0.0.0.0, Zeitstempel: 0x00000000
Ausnahmecode: 0x40000015
Fehleroffset: 0x000000000001f70a
ID des fehlerhaften Prozesses: 0x2380
Startzeit der fehlerhaften Anwendung: 0x01d8a035768f51f3
Pfad der fehlerhaften Anwendung: C:\Program Files\FileZilla Server\filezilla-server.exe
Pfad des fehlerhaften Moduls: C:\Program Files\FileZilla Server\libstdc++-6.dll
Berichtskennung: a75e5554-760d-4a82-8089-d3dc446e706e
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

comment:5 by Tim Kosse, 2 months ago

Status: newmoreinfo

You need to check in the %LOCALAPPDATA%\CrashDumps of the Windows account the server service is running under, SYSTEM by default.

Not in front of a Windows right now, if I remember correclty it's under c:\windows\system32\config\systemprofile by default.

comment:6 by Markus, 2 months ago

Status: moreinfonew

thanks, in this folder there are crashdumps... See attachment

comment:7 by Markus, 2 months ago

Can you please delete the attachement as soon as you downloaded it...

comment:8 by Tim Kosse, 2 months ago

Status: newmoreinfo

Unfortunately the crash dump was inconclusive.

What is needed is a dump from a build with debug symbols.

  1. Download https://filezilla-project.org/nightlies_server/2022-07-26/win64/FileZilla_Server_debug.tar.bz2
  2. Make sure the server is not running.
  3. Extract the contents of the tarball into FileZilla Server's installation directory, overwriting the old executables and libraries.
  4. Afterwards start the server
  5. Once it crashes, submit the fresh dump.

comment:9 by Markus, 2 months ago

Status: moreinfonew

I uploaded a Dump created with your debug version. Please delete again after download...

comment:10 by Tim Kosse, 2 months ago

Thanks for the dumps, I managed to reproduce the issue.

comment:11 by Tim Kosse, 2 months ago

Status: newmoreinfo

comment:12 by Markus, 2 months ago

Status: moreinfonew

Since the installation of the new version there was no crash any more.

Thanks a lot for your quick help!

comment:13 by Fabio Alemagna, 5 weeks ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.