Opened 5 months ago

Last modified 3 months ago

#12396 new Bug report

Webdav connection error, problem

Reported by: Bas Bosch Owned by:
Priority: normal Component: FileZilla Client
Keywords: Content-Length, Connection, Error, Redirections Cc:
Component version: Filezilla Pro, 3.52.2, webdav Operating system type: Windows
Operating system version: Windows 10 , 20H2, 19042.867

Description (last modified by Bas Bosch)

I can't manage to log in with Filezilla Pro with the same credentials I use for Android (Solid Explorer, webdav) and used for AirExplorer (Windows 10, webdav). Provider Ziggo.
With webdav Android and AirExplorer I get (got) a connection, I see the folder structure and can navigate through it..
With Filezilla Pro I do not get a connection at all:
Error: Too many redirections
Error: Failed to receive folder list
I have tried everything, no result.

A part of the log:
........ ........
Opdracht: Authorization:
Opdracht: Connection: keep-alive
Opdracht: Content-Length: 0
Opdracht: Depth: 1
Opdracht: Host: mail.ziggo.nl:443
Opdracht: Keep-Alive: 300
Opdracht: User-Agent: FileZilla/3.52.2
Antwoord: HTTP/1.0 301 Moved Permanently
Antwoord: Location: https://mail.ziggo.nl/servlet/webdav.infostore/
Antwoord: Server: BigIP
Antwoord: Connection: Keep-Alive
Antwoord: Content-Length: 0
Opdracht: PROPFIND /servlet/webdav.infostore/ HTTP/1.1
Opdracht: Authorization:

Opdracht: Connection: keep-alive
Opdracht: Content-Length: 0
Opdracht: Depth: 1
Opdracht: Host: mail.ziggo.nl:443
Opdracht: Keep-Alive: 300
Opdracht: User-Agent: FileZilla/3.52.2
Antwoord: HTTP/1.0 301 Moved Permanently
Antwoord: Location: https://mail.ziggo.nl/servlet/webdav.infostore/
Antwoord: Server: BigIP
Antwoord: Connection: Keep-Alive
Antwoord: Content-Length: 0
Fout: Te veel omleidingen
Fout: Ontvangen van mappenlijst is mislukt

Attachments (8)

connection.txt (3.4 KB ) - added by Bas Bosch 5 months ago.
Log file
Klembord001.jpg (118.6 KB ) - added by Bas Bosch 5 months ago.
Klembord002.jpg (103.8 KB ) - added by Bas Bosch 5 months ago.
Klembord003.jpg (121.1 KB ) - added by Bas Bosch 5 months ago.
Klembord04.jpg (154.9 KB ) - added by Bas Bosch 4 months ago.
Klembord05.jpg (78.4 KB ) - added by Bas Bosch 4 months ago.
Klembord06.jpg (37.5 KB ) - added by Bas Bosch 4 months ago.
Klembord01.jpg (39.6 KB ) - added by Bas Bosch 3 months ago.

Download all attachments as: .zip

Change History (18)

by Bas Bosch, 5 months ago

Attachment: connection.txt added

Log file

comment:1 by Bas Bosch, 5 months ago

Description: modified (diff)

comment:2 by Bas Bosch, 5 months ago

Version 3.53.0 same problem.

comment:3 by Bas Bosch, 5 months ago

I thought, let me try Winscp to see if I can login with that software. No problem at all.
Again I used the same serverinfo, credentials , etc in Filezilla. No result. I can not log in.

by Bas Bosch, 5 months ago

Attachment: Klembord001.jpg added

by Bas Bosch, 5 months ago

Attachment: Klembord002.jpg added

by Bas Bosch, 5 months ago

Attachment: Klembord003.jpg added

comment:4 by Tim Kosse, 5 months ago

Status: newmoreinfo

Antwoord: HTTP/1.0 301 Moved Permanently
Antwoord: Location: ​https://mail.ziggo.nl/servlet/webdav.infostore/

The server tells you that you are requesting the wrong resource.

Try entering /servlet/webdav.infostore/ as default remote directory.

comment:5 by Bas Bosch, 5 months ago

Status: moreinfonew

Thanks for your reply, much appreciated.

I entered /servlet/webdav.infostore/ , no result (also with /root)
This is what I get:
Antwoord: Connection: Keep-Alive
Antwoord: Content-Length: 0
Opdracht: PROPFIND / HTTP/1.1
Opdracht: Connection: keep-alive
Opdracht: Content-Length: 0
Opdracht: Depth: 1
Opdracht: Host: sync.ziggo.nl:443
Opdracht: Keep-Alive: 300
Opdracht: User-Agent: FileZilla/3.53.0
Antwoord: HTTP/1.0 302 Found
Antwoord: Location: https://sync.ziggo.nl/
Antwoord: Server: BigIP
Antwoord: Connection: Keep-Alive
Antwoord: Content-Length: 0
Fout: Te veel omleidingen
Fout: Ontvangen van mappenlijst is mislukt

With the other software (Winscp, Air Explorer and Solid Explorer Android) I can login, without any problems, with "mail.ziggo.nl/servlet/webdav.infostore" and/ or drive.ziggo.nl without filling out the remote directory!
As mentioned earlier, I use the same info, etc. Strange, strange. I bought Fulezilla Pro in order to use Webdav ..... What now? Workaround, or is it a bug or the way Filezilla is using commands ??

Last edited 5 months ago by Bas Bosch (previous) (diff)

comment:6 by Bas Bosch, 4 months ago

Version 3.53.1 : same problem, too many redirections.

It's a real shame, that I have to use WinSCP to log onto the drive at my internet provider. I have really tried everything with the same data from WinSCP.
Surely the fault lies with FilezillaPro, especially since I could also use Air Explorer , without problems.

*

Opdracht: PROPFIND / HTTP/1.1
Opdracht: Connection: keep-alive
Opdracht: Content-Length: 0
Opdracht: Depth: 1
Opdracht: Host: sync.ziggo.nl:443
Opdracht: Keep-Alive: 300
Opdracht: User-Agent: FileZilla/3.53.1
Antwoord: HTTP/1.0 302 Found
Antwoord: Location: https://sync.ziggo.nl/
Antwoord: Server: BigIP
Antwoord: Connection: Keep-Alive
Antwoord: Content-Length: 0
Fout: Te veel omleidingen
Fout: Ontvangen van mappenlijst is mislukt

comment:7 by Tim Kosse, 4 months ago

Status: newmoreinfo

Are you sure you entered /servlet/webdav.infostore/ as default remote directory? The log does not show an attempt to list this directory.

by Bas Bosch, 4 months ago

Attachment: Klembord04.jpg added

by Bas Bosch, 4 months ago

Attachment: Klembord05.jpg added

by Bas Bosch, 4 months ago

Attachment: Klembord06.jpg added

comment:8 by Bas Bosch, 4 months ago

Status: moreinfonew

Hi,

I tried everything: /servlet/webdav.infostore , / , /userstore, userstore (and personal folder), however no result.
I attach 3 screenshots from WinSCP (data, login and folder structure on the remote server)
Using the same data (from WinSCP) just does not work. As mentioned earlier, using the same data on my tablet (Solid Expolorer) is also OK, no problems ...

by Bas Bosch, 3 months ago

Attachment: Klembord01.jpg added

in reply to:  7 comment:9 by Bas Bosch, 3 months ago

Replying to Tim Kosse:

Are you sure you entered /servlet/webdav.infostore/ as default remote directory? The log does not show an attempt to list this directory.

With the latest version of FilezillaPro 3.54.1 Webdav still does work. As mentioned earlier no problems with Solid Explorer (Android) and Winscp.
Again and again and again I get too many redirections Funny, I bought the Pro version to use Webdav and ... this does not work.
Again a screenshot of Winscp.
Question: why do I get too many redirections when using FilezillaPro

in reply to:  7 comment:10 by Bas Bosch, 3 months ago

Replying to Tim Kosse:

Are you sure you entered /servlet/webdav.infostore/ as default remote directory? The log does not show an attempt to list this directory.

Note: See TracTickets for help on using tickets.