Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#12361 closed Bug report (worksforme)

context menu truncated

Reported by: Nick Levinson Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: Nick Levinson
Component version: 3.51.0 Operating system type: Linux
Operating system version: Fedora 33, kept evergreen

Description

A menu continues below the bottom of the viewport, so the bottom commands cannot be seen.

Steps to reproduce:

  1. This is based on the display resolution being 1440x900.
  1. Access a directory on either side of the window.
  1. Navigate to a directory that has no more than three folders (not counting the ".." pseudofolder) (I don't know whether the monitor's window size affects the number of folders and files relevant to this bug) and enough files to populate the pane to the bottom of the pane.
  1. Select the file on the bottom of the pane.
  1. Without vertically scrolling, context-click (usually right-click) that file. You'll get a menu but you won't be able to see the bottom of the menu.
  1. Tap the up-arrow just once. This will select the bottom command even though you can't see that selection.
  1. Keep tapping and count the taps (probably one or two more) until you have selected a command and you can read the selection.
  1. Tap esc to dismiss the menu without selecting a command.
  1. For a comparison showing proper menu behavior, select a file near the the top of the pane.
  1. Context-click that file. You'll get a menu and you'll be able to see all of it.
  1. Dismiss the menu without selecting a command.

Actuality: Truncation of menu, per STR 4.

Expectation: Whole menu no matter which file or folder we context-click.

Additional information:

When truncation could occur, the top of the menu should be above the file or folder selection, so that all of its commands are visible.

I tested selecting 3 adjacent files at the bottom of the viewport, putting the cursor (a pointer) at the bottom file in the selection, and context--clicking. The menu began at the cursor. Therefore, in some circumstances the menu should begin above the cursor, not at the cursor.

Change History (2)

comment:1 by Tim Kosse, 11 months ago

Resolution: worksforme
Status: newclosed

Cannot reproduce. Context menus opened near the bottom open upwards.

Try a different window manager.

comment:2 by Nick Levinson, 11 months ago

According to wmctrl -m in a terminal on my Fedora 33 Linux x86_64 platform with Gnome and kept evergreen, I run Gnome Shell. I generally keep default software and Settings doesn't say what window manager I use, so, if Gnome Shell is not it, I likely use metacity, and that's likely true for most users of Fedora, not an obscure distro.

My Ubuntu 20.04.1 LTS Linux x86_64 platform gives the same result for wmctrl -m and has FileZilla 3.46.3, where the menus work properly, but that FileZilla is old, so maybe the menu problem is a regression. I uninstalled it and then did a fresh installation of FileZilla and it's still 3.46.3; I don't know why.

Then, back on the Fedora platform, I uninstalled FileZilla via yum and reinstalled it via dnf but that didn't update the version from 3.51.0. FileZilla is now up to 3.52.0 but I can't get it in a way that assures coordination with the rest of the distro.

What window manager do you use? And shouldn't FileZilla's menus work properly with any well-known window manager? or do you think the window manager I use likely has a bug?

Note: See TracTickets for help on using tickets.