Opened 7 weeks ago

Last modified 5 weeks ago

#12033 new Bug report

FileZilla Pro (3.45.2) does not connect to S3 bucket via HTTP proxy with username/pwd

Reported by: Martin H. Owned by:
Priority: high Component: FileZilla Client
Keywords: s3 http proxy user password Cc:
Component version: 3.45.2 Operating system type: Windows
Operating system version: Windows10 64Bit

Description

I've tried to get access to our S3 bucket through an http proxy which has username and password restrictions. The debug shows that the connection to the proxy host is being established, but after the 407 response that an authentication is required, the attept failes with "ECONNRESET" - and I don't have a clue why.
The user name and password are correct so I assume that this is a kind of misunderstanding between FileZilla Pro and the squid proxy server.

Attachments (1)

S3_FileZilla_DEBUG_CONNECT.anon.png (75.3 KB) - added by Martin H. 7 weeks ago.
Log information on debug level showing the connection (try) via HTTP proxy

Download all attachments as: .zip

Change History (4)

Changed 7 weeks ago by Martin H.

Log information on debug level showing the connection (try) via HTTP proxy

comment:1 Changed 7 weeks ago by Tim Kosse

Status: newmoreinfo

Does your proxy support the CONNECT method of HTTP?

comment:2 Changed 7 weeks ago by Martin H.

Status: moreinfonew

Yes, it does - but on port 443 only (which has been committed
by the squid admin). All other ports don't support the CONNECT
method of HTTP.
I've tried with S3 Browser and it worked out in the same
environment, so I assume, that the proxy communication should
be directly involved in this problem (I'd really prefer to use
my FileZilla Pro :))

comment:3 Changed 5 weeks ago by Martin H.

Did you have some time to look into this problem?
Is there a way to use that proxy without having
it listening on port 80 using the CONNECT method?

Note: See TracTickets for help on using tickets.