Opened 7 months ago

Closed 6 months ago

#11909 closed Bug report (fixed)

Alias Not Working for Shared OneDrive Folder

Reported by: pitmancd Owned by:
Priority: critical Component: FileZilla Server
Keywords: alias shared folder name OneDrive Cc:
Component version: Operating system type: Windows
Operating system version: Windows 10, version 1809

Description

When I goto Users -> Shared Folders and try to create an alias to this OneDrive folder, it allows me to make the entry, but it does NOT work when connecting remotely to the server:

f:\OneDrive - company-tech.net

When connecting remotely to the shared folder, it will display the folder contents, but it won't allow a file transfer and fails. Filezilla Server reports this error:

550 Could not open file for reading.

But if I create the alias to this folder name, it will work:

f:\OneDrive

So I believe Filezilla Server is having an issue with the hyphen or period in the folder name.

I would use the simpler folder name, however, OneDrive does not allow me to change the name of the folder as that belongs to the OneDrive account name, which in this case is "company-tech.net".

Change History (4)

comment:1 Changed 7 months ago by pitmancd

Upon further investigation, after disconnecting/unlinking the OneDrive account and leaving the folder in place, I was able to connect and transfer files without issue. So apparently the issue is not with the filename but with having OneDrive syncing to that folder.

BTW, I was previously using Filezilla Server with a Dropbox folder, and that did not have any issues. So OneDrive must be doing something special with its folders by locking them somehow??

I would really like to find a work-around for OneDrive. Thanks!

comment:2 Changed 7 months ago by pitmancd

Keywords: OneDrive added

comment:3 Changed 7 months ago by pitmancd

Summary: Alias Not Working for Shared Folder NameAlias Not Working for Shared OneDrive Folder

comment:4 Changed 6 months ago by pitmancd

Resolution: fixed
Status: newclosed

So sorry, this was my mistake. On this particular server, I inadvertently checked this OneDrive option: Files On-Demand (Save space and download files as you use them).

So the files that I was trying to access via FileZilla weren't actually available locally on that server, and that's why I was getting errors.

Again, my apologies!

Note: See TracTickets for help on using tickets.