Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#11908 closed Bug report (fixed)

Cannot use FileZilla Client 3.42.0 on macOS 10.13.6

Reported by: Roland Trimmel Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: OS X
Operating system version: 10.13.6

Description

After upgrade from a previous version of Filezilla, upon opening the application an error message as follows appears:

"You can't use this version of the application 'FileZilla' with this version of macOS. You have macOS 10.13.6. The application requires macOS 10.14 or later."

In the Applications directory, the app symbol is shown with a semi-transparent crossed out symbol indicating that it cannot be used.

Attachments (4)

1 - error message.png (39.5 KB) - added by Roland Trimmel 6 months ago.
Error message
2 - about.png (114.4 KB) - added by Roland Trimmel 6 months ago.
About this Mac
Screen Shot 2019-05-09 at 06.13.15.png (28.7 KB) - added by Gary 5 months ago.
2019-05-09 _FZ 3.42.1 on MacOS 10.13.6.png (148.7 KB) - added by Roland Trimmel 5 months ago.
Update to FZ 3.42.1 but problem remains

Download all attachments as: .zip

Change History (17)

Changed 6 months ago by Roland Trimmel

Attachment: 1 - error message.png added

Error message

Changed 6 months ago by Roland Trimmel

Attachment: 2 - about.png added

About this Mac

comment:1 Changed 6 months ago by Tim Kosse

This looks like a bug in macOS 10.13, if your hardware supports it, consider updating to macOS 10.14

comment:2 Changed 5 months ago by rmraya

It's not a bug on macOS 10.13.6.

The program was built for running only on macOS 10.14.x

Unless you recompile with an older version of macOS, it will not work with previous versions of macOS

BTW, the download page says "Requires OS X 10.9 or newer"

comment:3 Changed 5 months ago by Tim Kosse

Unless you recompile with an older version of macOS, it will not work with previous versions of macOS

Bullshit. That is simply not the case. Case-in-point: FZ 3.41.2 was built on macOS 10.14 and runs fine on older versions.

comment:4 Changed 5 months ago by rmraya

Was previous version compiled using 10.14.4 or a previous macOS release like 10.14.3?

In any case, the important fact is that current FileZilla does not work on 10.13.6

comment:5 Changed 5 months ago by huehnergeier

I also got this problem with the filezilla pro upgrade from the apple appstore yesterday in the evening. Please fix it, because it is now unusable on older mac hardware. Cannot upgrade to macOs 10.14.

Changed 5 months ago by Gary

comment:6 Changed 5 months ago by Gary

I'm also running an older version of Mac OS and not able to update, the latest FileZilla Pro does not run on older versions of the OS, do you not build in checks or backward compatibility?

EDIT: There is now an update which works. Thank you!

Last edited 5 months ago by Gary (previous) (diff)

comment:7 in reply to:  1 Changed 5 months ago by Roland Trimmel

Replying to Tim Kosse:

This looks like a bug in macOS 10.13, if your hardware supports it, consider updating to macOS 10.14

Thanks for the swift reply. An update to macOS 10.14 is not possible as that version of the operating system is supported only on every Mac from 2012 or newer.

See the full list of devices supported and not supported in macOS 10.14 in this post - https://9to5mac.com/2018/06/04/macos-10-14-mojave-supported-macs/

While I'm upgrading my hardware to a new Mac as we speak, there probably is a fairly substantial number of people running devices that cannot upgrade to macOS 10.14. It would be helpful thus if these people can download an older version of FileZilla, as just before the automatic update to FileZilla Client 3.42.0 everything was working fine on my machine.

I believe that I was running FileZilla Client 3.41.x before, but can't tell unless someone can provide instructions on how to look this up.

comment:8 in reply to:  6 ; Changed 5 months ago by Roland Trimmel

Replying to Gary:

I'm also running an older version of Mac OS and not able to update, the latest FileZilla Pro does not run on older versions of the OS, do you not build in checks or backward compatibility?

EDIT: There is now an update which works. Thank you!

@Gary: Can you clarify on which update you refer to? I did complete a download of their sponsored installer from the FileZilla website just now (triggered by your comment), but run into the same issue experienced as before.

comment:9 in reply to:  8 Changed 5 months ago by Gary

Replying to Roland Trimmel:

Replying to Gary:

I'm also running an older version of Mac OS and not able to update, the latest FileZilla Pro does not run on older versions of the OS, do you not build in checks or backward compatibility?

EDIT: There is now an update which works. Thank you!

@Gary: Can you clarify on which update you refer to? I did complete a download of their sponsored installer from the FileZilla website just now (triggered by your comment), but run into the same issue experienced as before.

This was done through the App Store on Mac

comment:10 Changed 5 months ago by Tim Kosse

Resolution: fixed
Status: newclosed

Please update to FileZilla 3.42.1

Changed 5 months ago by Roland Trimmel

Update to FZ 3.42.1 but problem remains

comment:11 in reply to:  10 Changed 5 months ago by Roland Trimmel

Replying to Tim Kosse:

Please update to FileZilla 3.42.1

@Tim: Thanks for the info and just did that. But see the file I uploaded, problem remains the same on my system.

Any logs I can send over for you to analyze?

comment:12 Changed 5 months ago by Tim Kosse

macOS caches some application data in memory and may remember outdated information.

Please delete FileZilla and empty your trash, then reboot, then reinstall it.

comment:13 in reply to:  12 Changed 5 months ago by Roland Trimmel

Replying to Tim Kosse:

macOS caches some application data in memory and may remember outdated information.

Please delete FileZilla and empty your trash, then reboot, then reinstall it.

Thanks, and confirmed. I followed your suggested procedure and FileZilla is now up and running again on macOS 10.13.6.

Note: See TracTickets for help on using tickets.