#11760 closed Bug report (duplicate)

Compilation error in 3.37.3

Reported by: Florian Pritz Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.37.3 Operating system type: Linux
Operating system version: Arch Linux

Description

I'm seeing the compliation error below starting with filezilla client 3.37.3. 3.37.1 compiles just fine. See the attached file for the full log.

I'm building as follows:

./configure \

--prefix=/usr \
--disable-manualupdatecheck \
--disable-autoupdatecheck \
--with-pugixml=builtin \
--with-wx-config=/usr/bin/wx-config-gtk3

make

### output

queue.cpp: In member function ‘void CFileItem::SetTargetFile(const wxString&)’:
queue.cpp:333:71: error: no matching function for call to ‘to_wstring(const wxString&)’

m_targetFile = fz::sparse_optional<std::wstring>(fz::to_wstring(file));


In file included from /usr/include/libfilezilla/libfilezilla.hpp:7,

from ../../src/include/libfilezilla_engine.h:12,
from filezilla.h:4:

/usr/include/libfilezilla/string.hpp:145:31: note: candidate: ‘std::cxx11::wstring fz::to_wstring(const string&)’

std::wstring FZ_PUBLIC_SYMBOL to_wstring(std::string const& in);

~

/usr/include/libfilezilla/string.hpp:145:31: note: no known conversion for argument 1 from ‘const wxString’ to ‘const string&’ {aka ‘const std::cxx11::basic_string<char>&’}
/usr/include/libfilezilla/string.hpp:148:38: note: candidate: ‘std::
cxx11::wstring fz::to_wstring(const wstring&)’

inline std::wstring FZ_PUBLIC_SYMBOL to_wstring(std::wstring const& in) { return in; }

~

/usr/include/libfilezilla/string.hpp:148:38: note: no known conversion for argument 1 from ‘const wxString’ to ‘const wstring&’ {aka ‘const std::cxx11::basic_string<wchar_t>&’}
/usr/include/libfilezilla/string.hpp:152:98: note: candidate: ‘template<class Arg> typename std::enable_if<std::is_arithmetic<typename std::decay<_Tp>::type>::value, std::
cxx11::basic_string<wchar_t> >::type fz::to_wstring(Arg&&)’

inline typename std::enable_if<std::is_arithmetic<std::decay_t<Arg>>::value, std::wstring>::type to_wstring(Arg && arg)

~

/usr/include/libfilezilla/string.hpp:152:98: note: template argument deduction/substitution failed:
/usr/include/libfilezilla/string.hpp: In substitution of ‘template<class Arg> typename std::enable_if<std::is_arithmetic<typename std::decay<_Tp>::type>::value, std::cxx11::basic_string<wchar_t> >::type fz::to_wstring(Arg&&) [with Arg = const wxString&]’:
queue.cpp:333:71: required from here
/usr/include/libfilezilla/string.hpp:152:98: error: no type named ‘type’ in ‘struct std::enable_if<false, std::
cxx11::basic_string<wchar_t> >’
mv -f .deps/filezilla-netconfwizard.Tpo .deps/filezilla-netconfwizard.Po

Attachments (1)

filezilla-3.37.3-1-x86_64-build.log (116.4 KB) - added by Florian Pritz 14 months ago.

Download all attachments as: .zip

Change History (3)

Changed 14 months ago by Florian Pritz

comment:1 Changed 13 months ago by yan12125

This is a duplicate of https://trac.filezilla-project.org/ticket/11759; I gave a workaround there.

comment:2 Changed 13 months ago by Tim Kosse

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.