#11565 closed Bug report (rejected)

FZ Server delete files from the server during drag-and-drop operation in Windows Explorer w/Clover addon

Reported by: Branimir Zivkoivc Owned by:
Priority: normal Component: FileZilla Server
Keywords: drag&drop, delete, missing files Cc:
Component version: 0.9.60.2 Operating system type: Windows
Operating system version: Windows 8.1. 6.3.9600

Description

This bug applies to all version of FZ Server, even the newest one, while using Windows Explorer and Clover extension for Windows Explorer (in order to have folder tabs).

During drag&drop operation between local folder and ftp folder managed by FZ Server, FZ Server will delete file if drag&drop operation was unsuccessful (if source file is dropped on ribbon bar).

If you successfully drag file from ftp folder and drop it in local folder tab (folder window), file will be copied and source file will remain intact.

If you accidentally drag&drop source file to the Windows Explorer (in my case w/Clover) ribbon bar, FZ Server will delete file (with DELE command.)

It's better to check this soon, because today I've lost my files just by doing plain drag&drop operation. It may be not even FZ Server bug, but it's better to be sure it's Windows Explorer or Clover to blame for.

Video explanation of the bug:
https://www.youtube.com/watch?v=rKuVM3n1Q2g

Log:
(000005) 9.4.2018. 14:03:59 - locus (192.168.1.21)> noop
(000005) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 200 OK
(000005) 9.4.2018. 14:03:59 - locus (192.168.1.21)> CWD /r/fz_mystery_deleted/
(000005) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 250 CWD successful. "/r/fz_mystery_deleted" is current directory.
(000005) 9.4.2018. 14:03:59 - locus (192.168.1.21)> DELE fz_will_delete_this_file.CR2
(000005) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 250 File deleted successfully
(000006) 9.4.2018. 14:03:59 - (not logged in) (192.168.1.21)> Connected on port 21, sending welcome message...
(000006) 9.4.2018. 14:03:59 - (not logged in) (192.168.1.21)> 220-FileZilla Server 0.9.60 beta
(000006) 9.4.2018. 14:03:59 - (not logged in) (192.168.1.21)> 220-written by Tim Kosse (tim.kosse@…)
(000006) 9.4.2018. 14:03:59 - (not logged in) (192.168.1.21)> 220 Please visit https://filezilla-project.org/
(000006) 9.4.2018. 14:03:59 - (not logged in) (192.168.1.21)> USER locus
(000006) 9.4.2018. 14:03:59 - (not logged in) (192.168.1.21)> 331 Password required for locus
(000006) 9.4.2018. 14:03:59 - (not logged in) (192.168.1.21)> PASS *
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 230 Logged on
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> SYST
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 215 UNIX emulated by FileZilla
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> FEAT
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 211-Features:
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> MDTM
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> REST STREAM
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> SIZE
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> MLST type*;size*;modify*;
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> MLSD
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> UTF8
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> CLNT
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> MFMT
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> EPSV
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> EPRT
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 211 End
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> OPTS UTF8 ON
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 202 UTF8 mode is always enabled. No need to send this command.
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> PWD
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 257 "/" is current directory.
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> TYPE I
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 200 Type set to I
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> PASV
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 227 Entering Passive Mode (192,168,1,22,244,55)
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> SIZE /r/fz_mystery_deleted/fz_will_delete_this_file.CR2
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 550 File not found
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> MDTM /r/fz_mystery_deleted/fz_will_delete_this_file.CR2
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 550 File not found
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> RETR /r/fz_mystery_deleted/fz_will_delete_this_file.CR2
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 550 File not found
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> PASV
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 227 Entering Passive Mode (192,168,1,22,232,198)
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> CWD /r/fz_mystery_deleted/fz_will_delete_this_file.CR2
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 550 CWD failed. "/r/fz_mystery_deleted/fz_will_delete_this_file.CR2": directory not found.
(000006) 9.4.2018. 14:03:59 - locus (192.168.1.21)> disconnected.

Change History (1)

comment:1 Changed 20 months ago by Tim Kosse

Resolution: rejected
Status: newclosed

Not a bug in FileZilla Server.

(000005) 9.4.2018. 14:03:59 - locus (192.168.1.21)> DELE fz_will_delete_this_file.CR2
(000005) 9.4.2018. 14:03:59 - locus (192.168.1.21)> 250 File deleted successfully

Your The FTP client sent the DELE command and FileZilla Server correctly performed the requested action.

Note: See TracTickets for help on using tickets.