Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#11552 closed Bug report (rejected)

Search remote files (F3) without results when using wildcards

Reported by: Laurents Meyer Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.31.0 Operating system type: Windows
Operating system version:

Description

If you are using an asterisk ("*") wildcard in any query (i.e. contains) except the regex query in the search remote files dialog, there will be no results.

As a workaround, a regular expression can be used, which is working as expected.

Change History (2)

comment:1 Changed 19 months ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is by design, otherwise users could not search for files containing an asterisk without having to use escape sequences.
As there are already the even more powerful regular expressions, there's no need to add wildcard support.

comment:2 Changed 19 months ago by Laurents Meyer

I think that is very reasonable. I haven't been aware of the fact, that an asterisk is actually a legal character outside the Windows environment.

Though I would suggest then to remove the default asterisk from the text box/edit control, because it suggests for anybody familiar with wildcards, that it is the default for finding every file instead of finding only files containing an asterisk (which is a very odd choice for a default search query by the way).

Note: See TracTickets for help on using tickets.