Opened 17 months ago

Last modified 4 weeks ago

#11526 new Bug report

wxGTK3 Linux: small fonts in directory trees

Reported by: Alex Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc: alevkovich@…
Component version: Operating system type: Linux
Operating system version:

Description

Archlinux, Filezilla compiled with wxGTK v. 3.0.3.1.
The better decription of the problem is the pictures I attached.
I think all fonts of all controls should have the same size like it was with GTK2 build.

Attachments (2)

1.png (87.8 KB) - added by Alex 17 months ago.
visual description of the problem
Screenshot_20190318_010358.png (191.3 KB) - added by funneel3434 4 months ago.

Download all attachments as: .zip

Change History (8)

Changed 17 months ago by Alex

Attachment: 1.png added

visual description of the problem

comment:1 Changed 17 months ago by Alex

I forgot to say about the main fact: you need to increase your dpi from standard 96 to 125 for example. It is not problem GTK3 because I have other GTK3 programs and they are ok with treeview's font. One more thing: only treeview widget affected. The fonts in all other widgets are ok.

comment:2 Changed 17 months ago by Tim Kosse

Priority: criticallow

Changed 4 months ago by funneel3434

comment:3 Changed 4 months ago by funneel3434

Same issue here with a HiDPI screen on a 4K resolution. In my situation Filezilla is unusable (see screenshot) as I use my TV as a monitor and sit 5m away from it, e.g. I cannot read the tiny text.

Tried the following so far:

GDK_SCALE=2
GDK_DPI_SCALE=2

These increase the font size of the interface which is already OK, the tree widget's font size is not affected and remains tiny.

.config/gtk-3.0/settings.ini:

gtk-xft-dpi=196608

This produces no effect.

Using Filezilla 3.39.0 with wxGTK-3.0.4.

Last edited 4 months ago by funneel3434 (previous) (diff)

comment:4 Changed 4 months ago by funneel3434

Priority: lowhigh

comment:5 Changed 4 weeks ago by Mavelli

i have the same issue -
filezilla 3.42.1-1
wxgtk3 3.0.4-2
gtk3 1:3.24.9-1

does it maybe have something to do with https://bugzilla.gnome.org/show_bug.cgi?id=757142 ?

comment:6 Changed 4 weeks ago by Mavelli

workaround:

GDK_SCALE=2 GDK_DPI_SCALE=0.4 filezilla

works for me ballancing the strange wxPizza elements small fonts back to normal. it behaves strange.

i also tried to change the text of the wxPizza elements with .config/gtk-3.0/gtk.css but there i just cannot find the right elements and labels to address precisely. i can resize font of all gtk3 elements (*{font-size:60px} or something) but this breaks all other gtk3 windows on the system.

Note: See TracTickets for help on using tickets.