#11457 closed Feature request (wontfix)

Wrong "request-id" in SSH packet when sending over SFTP

Reported by: Piotr Owned by:
Priority: high Component: FileZilla Client
Keywords: sftp Cc:
Component version: FileZilla 3.29.0 Operating system type: Windows
Operating system version: Windows Server 2012

Description

SFTP server: Solarwinds Serv-U 15.1.5.10.
Client: FileZilla 3.29.0

FileZilla sends a constant "request-id" in each packet.
According to RFC https://tools.ietf.org/id/draft-ietf-secsh-filexfer-13.txt:

'request-id'

Each request from the client contains a 'request-id' field. Each
response from the server includes that same 'request-id' from the
request that the server is responding to. One possible
implementation is for the client to us a monotonically increasing
request sequence number (modulo 232). There is, however, no
particular requirement the 'request-id' fields be unique.

The server shows 'request-id' in braces.
Example line as follows:
[30] Fri 24Nov17 09:04:58 - (000015) {0x00000100} SSH_FXP_REALPATH: path: "."

'request-id' is 0x00000100 in this packet. Replay should contains the same number.

The problem is that FileZilla always sends the same 'request-id'. It makes the log analysis very difficult especially that according to the standard, the SFTP commands don't have to be send in the same sequence. I have tried other client software and this behaviour is present only when using FileZilla client.

Attaching:
FileZillaLog.txt: Log from the client, level 4
ServerLog - ClientFileZilla.txt: Full logs of FileZilla's session from the server
ServerLog - ClientWinSCP.txt: Full logs of WinSCP's session from the server as reference of a good session.

I'm not considering this behaviour as a bug since standard says it is not a mandatory to have an unique id, however it is very important feature request for troubleshooting purposes.

Attachments (3)

FileZillaLog.txt (2.3 KB) - added by Piotr 22 months ago.
ServerLog - ClientFileZilla.txt (1.9 KB) - added by Piotr 22 months ago.
ServerLog - ClientWinSCP.txt (1.8 KB) - added by Piotr 22 months ago.

Download all attachments as: .zip

Change History (4)

Changed 22 months ago by Piotr

Attachment: FileZillaLog.txt added

Changed 22 months ago by Piotr

Changed 22 months ago by Piotr

comment:1 Changed 22 months ago by Tim Kosse

Resolution: wontfix
Status: newclosed

There is, however, no particular requirement the 'request-id' fields be unique.

Note: See TracTickets for help on using tickets.