Opened 2 years ago

Last modified 2 years ago

#11329 reopened Bug report

[gtk3] -/+ buttons overlapping labels

Reported by: fruthaclao Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.26.2 Operating system type: Linux
Operating system version: Fedora 26

Description

The -/+ buttons that appear in various places throughout the interface overlap labels that appear to their right. An example includes the "Adjust server timezone offset" fields in the "Advanced" tab for a site in "Site Manager" ... the -/+ buttons overlap "Hours" and "Minutes" (see screen capture). Screen capture is from Fedora 26, where FileZilla is compiled against GTK3. I will also add a screen capture for reference showing how this looked when it was right in Fedora 21 (when FileZilla was compiled against GTK2).

Attachments (2)

f26.png (36.1 KB) - added by fruthaclao 2 years ago.
shows problem -- see "Hours" and "Minutes" fields (from Fedora 26, where FileZilla is compiled against GTK3)
f21.png (36.4 KB) - added by fruthaclao 2 years ago.
shows when these appeared correctly -- see "Hours" and "Minutes" fields (from Fedora 21, where FileZilla is compiled against GTK2)

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by fruthaclao

Attachment: f26.png added

shows problem -- see "Hours" and "Minutes" fields (from Fedora 26, where FileZilla is compiled against GTK3)

Changed 2 years ago by fruthaclao

Attachment: f21.png added

shows when these appeared correctly -- see "Hours" and "Minutes" fields (from Fedora 21, where FileZilla is compiled against GTK2)

comment:1 Changed 2 years ago by Tim Kosse

Resolution: wontfix
Status: newclosed

It's a bug in GTK3. In an attempt to emulate shitty mobile UIs that have to be touch-operated, they've dropped vertically stacked spin buttons.

comment:2 Changed 2 years ago by fruthaclao

Resolution: wontfix
Status: closedreopened

the folks running the gtk3 project are pretty frustrating -- but could you clarify ... is it the case that FileZilla doesn't aim to ever support gtk3?

or, could the (now-unsupported) vertically stacked spin buttons be replaced with horizontal ones (at least for when filezilla is compiled against gtk3) to address this? (or could the labels be positioned in a way that accounts for whatever sizing the spin buttons take?)

comment:3 Changed 2 years ago by Tim Kosse

The issue is more complicated. It already uses a horizontal spin control. Notice however, how the control renders itself outside of the assigned size, causing it to render over the labels.

There's little I can do if the controls don't even respect their assigned size.

comment:4 Changed 2 years ago by fruthaclao

most of my interface layout experience is with HTML, so perhaps this doesn't translate over, but couldn't you use something like a table, whose cells can adjust to accommodate whatever size their contents happen to be? or perhaps you're already using something like a table, and the fix is as simple as removing an explicit size specification on the cell containing the controls so that it will automatically stretch?

please see example of how this is accomplished in html (notice that when you switch to a larger image on the left, the label position on the right is adjusted accordingly):
https://codepen.io/anon/pen/oevgJG

Note: See TracTickets for help on using tickets.