Opened 3 years ago

Last modified 3 years ago

#11234 reopened Bug report

Duplicating directories locally on Mac 3.25.1

Reported by: codeplotter Owned by:
Priority: normal Component: FileZilla Client
Keywords: duplication copying files Cc: codeplotter@…
Component version: 3.25.1 Operating system type: OS X
Operating system version: 10.12.4

Description

Filezilla is creating copies of folders inside other existing folders. I am finding that if, on the local directory side, one folder is highlighted... and then I click and hold the arrow to open a folder below it, a green + appears, and when I let go of the mouse it gives an error message about not being able to create files in a directory. Then I start seeing copies of the highlighted folder inside the other folder. Filezilla has become unusable for me because it is creating and burying copies of folders locally faster than I can remove them.

Attachments (2)

1.png (57.9 KB) - added by codeplotter 3 years ago.
2.jpg (211.5 KB) - added by codeplotter 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 years ago by codeplotter

I downloaded version 3.17 and am having a similar problem. I am wondering if this has to do with the 10.12.4 Sierra update I downloaded very recently.

comment:2 Changed 3 years ago by Tim Kosse

Priority: criticallow
Resolution: invalid
Status: newclosed

From https://trac.filezilla-project.org/wiki/NewTicketFormGuide:

Priority: Leave it at normal, even if the problem is important for you. The developers will decide how important this problem really is.
Tickets that are filled out incorrectly will get rejected.

comment:3 Changed 3 years ago by codeplotter

Priority: lownormal
Resolution: invalid
Status: closedreopened

Updating status per above guidelines.

comment:4 Changed 3 years ago by Tim Kosse

Status: reopenedmoreinfo_reopened

What exactly do you mean by "I click and hold the arrow"?

Changed 3 years ago by codeplotter

Attachment: 1.png added

Changed 3 years ago by codeplotter

Attachment: 2.jpg added

comment:5 Changed 3 years ago by codeplotter

Status: moreinfo_reopenedreopened

I have attached a couple screenshots. Shot 1 is me clicking on the expand arrow/icon. It doesn't show in the screenshot, but a green + sign also appears at the same time. Screenshot 2 shows what I see after I release the click - even though I didn't move the mouse at all. Please let me know if I can provide more detail, thanks.

comment:6 Changed 3 years ago by Tim Kosse

Status: reopenedmoreinfo_reopened

According to the screenshot you have been initiating a drag&drop operation.

I had a look at the internals of wxWidgets, a drag operation is initiated after the mouse has been moved times by any amount of pixels.

Are you absolutely certain you didn't move the mouse? It can be hard to see on a high-resolution screen.

comment:7 Changed 3 years ago by codeplotter

Status: moreinfo_reopenedreopened

I maybe moved the mouse a pixel or two but not enough that it should be dragging anything

Note: See TracTickets for help on using tickets.