Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#10754 closed Bug report (rejected)

Unable to maintain file timestamp when pushing files to Toshiba 4690 OS

Reported by: BillS Owned by:
Priority: normal Component: FileZilla Client
Keywords: timestamp 4690 netterm Cc:
Component version: 3.15.01 Operating system type: Windows
Operating system version: 7 Professional

Description

I have used another program (NetTerm) to successfully push files from Windows to Toshiba 4690 OS and it is able to maintain the original timestamp. I could push a file to 4690 OS and capture the session using Wireshark if that would help to determine how it's working for NetTerm (SecureNetTerm actually) and send that to you.

Attachments (1)

Debug.txt (5.4 KB ) - added by BillS 4 years ago.
Copy/paste from FileZilla log with debug level 3.

Download all attachments as: .zip

Change History (4)

by BillS, 4 years ago

Attachment: Debug.txt added

Copy/paste from FileZilla log with debug level 3.

comment:1 by BillS, 4 years ago

Found this note deep inside one of the 4690 manuals. Hoping it might possibly be helpful:

"With SSH/SFTP the -p flag is by design, not supported when using the GET and PUT
interactive commands. The "Preserve timestamp" option in WinSCP translates to the -p
option on SFTP GET and PUT commands. According to the standard, if the -p flag is
specified on a GET or PUT, then the full file permissions and access times are copied to the remote host. In SSH2 terms, the command is SETSTAT (9) with at attribute to modify the file timestamp (8). If you change the WinSCP settings 'Preserve time stamp' to disable, then the SSH2 command will not be rejected by the 4690 SFTP server as an unsupported operation."

comment:2 by Tim Kosse, 4 years ago

Resolution: rejected
Status: newclosed

Packet dumps won't be of any use, all SFTP traffic is encrypted.

The manual text is very confusing, it refers to up user-level commands in third-party clients. It should speak in technical terms of the underlying protocol.
Protocol specifications for SFTP are here: https://filezilla-project.org/specs/draft-ietf-secsh-filexfer-02.txt

According to the confused wording of the manual, as well as the error message you are getting, your server simply does not support setting timestamps via SFTP.

(Secure)NetTerm must be setting timestamps via some other protocol.

comment:3 by Tim Kosse, 4 years ago

Precisely, your server does not support packets of type SSH_FXP_SETSTAT with flags set to SSH_FILEXFER_ACMODTIME.

Note: See TracTickets for help on using tickets.