Opened 14 years ago

Last modified 6 years ago

#1072 closed Bug report

Corrupting Files with SFTP on Linux

Reported by: terrychamilton Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: terrychamilton, Tim Kosse, marguskohv, Alexander Schuch
Component version: Operating system type:
Operating system version:

Description

When I send a number of files over SFTP some of the
files will end up getting their names mixed up.

For example:

Queue up 10 files IMAGE001.gif to IMAGE010.gif

001 is 1kb
002 is 2kb
...
010 is 10kb

After the batch is done the receiver has the files as:

001 is 2kb (001 is really 002 but mis-named)
002 is 1kb (it's really 001)
003 ok
...
009 is 10kb (it's really 010)
010 is 9kb (it's really 009)

It happens to any files, binary or text (GIF, PHP,
HTML, PDF, etc.). So far there has been no actual
corruption of the files, just the switching of filenames.

Randomly positioned in the upload order, not always the
first or last files.

The files switched are always sequencial in the list of
files (alphabetical) and it always happens in pairs.

It seems pretty random. Sometimes it will be 50% or
more of the files other times it will be 2 out of 30.

Uploading/Downloading from Windows to Redhat SFTP.
Happens across multiple hosts (and hosting services).

It happens both ways, getting and sending files.

Not related to the file names as simply re-sending the
files works. Next attempt will likely be different
files in the list.

Change History (6)

comment:1 by Tim Kosse, 14 years ago

Are you using any routers? Almost all users experiencing
problems with swapped filenames were using Linksys routers
so far.

comment:2 by terrychamilton, 14 years ago

Yes. Linksys WRT54G firmware 4.20.7.

So far I haven't detected any file corruption other than the
random name swapping.

comment:3 by marguskohv, 14 years ago

Happened to me too when downloading MULTIPLE FILES ! Files
are not corrupt, it just swaps filenames. If downloading
files one by one everything is okay. I am using FZ 2.2.27.

comment:4 by marguskohv, 14 years ago

Oh, and I have LinkSys router too... what should something
like that have anything to do with router ?

comment:5 by marguskohv, 14 years ago

Sorry for so many posts, but I think I've solved this issue
temporarily. By enabling "Active Transfer Mode" all files
were downloaded correctly. Hopefully this helps someone :)

comment:6 by Alexander Schuch, 13 years ago

So the problem with a Linksys router has been worked around?
If not, simply re-open this bug report.

Note: See TracTickets for help on using tickets.