Opened 4 years ago

Closed 4 years ago

#10608 closed Bug report (outdated)

Filezilla server doesnt retain settings after reboot

Reported by: ck Owned by:
Priority: normal Component: FileZilla Server
Keywords: lost settings Cc:
Component version: Operating system type: Windows
Operating system version: 7 32 bit sp2

Description

Filezilla server 0.9.48 beta was installed on Windows xp and Windows 7.
Multiple users were defined. The server settings return to blank after a reboot inwin7 but are retained in windows xp.
After every reboot all acounts have to be re-entered.
Before reboot, the accounts are listed OK.
After reboot, the accounts are all gone no groups users or folders are shown.
Attempted to add system permissions to folders used by the filzilla xml file. Seems to be a sandbox situation, but unable to find any settings to mitigate. Migrate the settings file(s) location to users\$user$\appdata\filezilla in windows 7 and perhaps it will retain settings.

Change History (2)

comment:1 Changed 4 years ago by ck

To check my bug submission, I thought I'd better verify where the config file resides.
I just checked and it is using the \users\%user%\appdata\filezilla for an xml file, and even after checking all permissions the behavior continues, settings will be cleared after reboot.
Looking at the content of the file before reboot, it appears to have usernames/passwords in the clear, in xml format.
So Windows must be replacing that file with a previous or factory version, after reboots. I have heard of this behavior in windows7, maybe I have to copy the file elsewhere, restore it in safe mode then reboot to get the settings to stick.
Evidently there is a setting somewhere in installers or elsewhere, that will allow updates of these type of files in this location.
_

comment:2 Changed 4 years ago by Tim Kosse

Resolution: outdated
Status: newclosed

You need to update to the most recent version of FileZilla Server. Old versions are not supported.

Note: See TracTickets for help on using tickets.