Opened 6 years ago

Closed 6 years ago

#10278 closed Bug report (worksforme)

Enabling speed-limit results in corrupt downloads

Reported by: Mummball Owned by:
Priority: normal Component: FileZilla Client
Keywords: speedlimit corrupt archive 3.10.2 Cc:
Component version: Operating system type: Windows
Operating system version: 7 Professional

Description

When downloading in

with Speedlimit
e.g. parameters
Down 400 KiB/s
Up 200 KiB/s
archive-Files like ZIP or GZ are downloaded in correct file size but are sometimes, but not always corrupt, this depends on the file size.
The bigger in size the more sure the file will be corrupt.
When trying to extract such a file with 7Zip the error message will be either
"Data error in archived_filename. File is broken" or
"Can not open ArchiveFilename as an archive" or
"An attempt was made to move the file pointer before the beginning of the file."

FileZilla Client


Version: 3.10.2

Build information:

Compiled for: i686-w64-mingw32
Compiled on: x86_64-unknown-linux-gnu
Build date: 2015-03-02
Compiled with: i686-w64-mingw32-gcc (GCC) 4.9.1
Compiler flags: -msse -mfpmath=sse -O2 -g -Wall -g -std=gnu++11

Linked against:

wxWidgets: 3.0.3
GnuTLS: 3.3.13
SQLite: 3.8.8.3

Operating system:

Name: Windows 7 (build 7601, Service Pack 1), 64-bit edition
Version: 6.1
Platform: 64-bit system

Attachments (5)

with_speedlimit.log (6.3 KB ) - added by Mummball 6 years ago.
without_speedlimit.log (2.9 KB ) - added by Mummball 6 years ago.
DOM_00266_01_Domains_with_speedlimit.zip (175.4 KB ) - added by Mummball 6 years ago.
with speed limit
DOM_00266_01_Domains_without_speedlimit.zip (175.4 KB ) - added by Mummball 6 years ago.
without speed limit
20150311_FZServer_encrypted_limited.txt (890 bytes ) - added by Mummball 6 years ago.
Test with TLS 1.0 FZ Server speed limit enabled

Download all attachments as: .zip

Change History (21)

by Mummball, 6 years ago

Attachment: with_speedlimit.log added

by Mummball, 6 years ago

Attachment: without_speedlimit.log added

comment:1 by Tim Kosse, 6 years ago

Status: newmoreinfo

I've been unable to reproduce this.

archive-Files like ZIP or GZ are downloaded in correct file size but are sometimes, but not always corrupt, this depends on the file size.

Please quantify what "sometimes" means, e.g. one out of ten? One out of a million?

What is the nature of the corruption? If possible, please attach a sample corrupted file as well as the uncorrupted version.

comment:2 by Mummball, 6 years ago

Status: moreinfonew

Hi,

every day I am transporting about 40 archives of which up to 4 files are corrupted.
So one out of ten is a good guess.
the problem is, that I cannot upload the files here because of file size limitations.
Even compressed with 7zips ultra compression the file has 361 Kilobibytes.
Can I Upload the files somewhere else for you?

in reply to:  2 comment:3 by Mummball, 6 years ago

Replying to mummball:

Hi,

every day I am transporting about 40 archives of which up to 4 files are corrupted.
So one out of ten is a good guess.
the problem is, that I cannot upload the files here because of file size limitations.
(Maximum attachment size: 262144 bytes)

Even compressed with 7zips ultra compression the file has 361 Kilobibytes.

Can I Upload the files somewhere else for you?

comment:4 by Tim Kosse, 6 years ago

You can mail the files to tim.kosse@…

by Mummball, 6 years ago

with speed limit

by Mummball, 6 years ago

without speed limit

comment:5 by Mummball, 6 years ago

mailed the original files as suggested

comment:6 by Tim Kosse, 6 years ago

Status: newmoreinfo

Thanks. The corrupted files, and only those, contain very strange data.

It very much looks like somehow raw SMB2 network packets made it into the files, including server names, IP addresses, Printer names, GUIDs and so on.

I don't think it's a bug in FileZilla. It looks more like faulty networking equipment or a driver issue.

Do you also experience this issue from other computers connecting to the same server?

Does it happen when you transfer files from a different server?

comment:7 by Mummball, 6 years ago

Status: moreinfonew

No, the other computers did not have parametrized the Speed-Limit and were not facing this issue.

I am having this problem when connecting to 2 different FTP-Servers.
Can you be more precise about which tools and actions you took for reading the broken files, so I can investigate ?
Or can you give me the information in TXT by e-Mail so I can check with the drivers.
It is strange because file and printer sharing for microsoft networks is disabled
Any suggestions will be much appreciated.

comment:8 by Tim Kosse, 6 years ago

Status: newmoreinfo

I've been using strings and xxd to look into the files and compared them using diff.

My current hypothesis:

When the speed is limited, the server sends data faster than the client receives, so arriving data gets buffered in the TCP stack until the advertised receive window is filled up. For some reason the buffered data gets corrupted, though not the housekeeping data, e.g its length.
The larger the file, or the slower the speed limit, the longer data remains buffered. This would explain why larger files seem to corrupt more commonly.

Googling for "NIC driver data corruption" yields some interesting articles as well, e.g. this one: http://www.zdnet.com/article/realtek-network-driver-silently-corrupts-data/

Try upgrading your NIC drivers. Don't rely on automated checking functionality, manually browse the vendor website for drivers to make sure you are using/getting the latest driver version.

comment:9 by Mummball, 6 years ago

Status: moreinfonew

Hi
I have tried updating the NIC drivers.
Without any avail.

comment:10 by Tim Kosse, 6 years ago

Status: newmoreinfo

In situations like this, a good way to detect corruption is to use FTP over TLS. As soon as data gets corrupted, the transfer gets interrupted and FileZilla will automatically retry and resume the transfer.

Unfortunately the server does not support FTP over TLS as it rejects the AUTH command.

Would it be possible for the server to be reconfigured/updated to support explicit FTP over TLS?

comment:11 by Mummball, 6 years ago

Status: moreinfonew

The FTP-Servers from which I am downloading the Zip-Files are not adminstrated by me/us.
But ok, I did as suggested within my own environment with filezilla server for test purposes.
When downloading with speed limitation error messages appear.
See attached file of today
20150311_FZServer_encrypted_limited.txt

comment:12 by Mummball, 6 years ago

PS: when disabling the speed limit while transferring the test 7-zip file is transmitted without further errors and can be fully functional decompressed.

by Mummball, 6 years ago

Test with TLS 1.0 FZ Server speed limit enabled

comment:13 by Tim Kosse, 6 years ago

Status: newmoreinfo

Does it also happen if installing and connecting to FileZilla Server on the same machine as the client?

comment:14 by Tim Kosse, 6 years ago

Are you by chance using AVG? It causes file corruption when using FTP.

See #10317

comment:15 by Mummball, 6 years ago

Status: moreinfonew

hi, sorry for not answer your question. I was ill and then in holidays..
No I am not using AVG and I disabled also temporarily my security solution for th tests.
I assume that FZ is just and indicator and that the error is only in my PC within the network config.
I will reinstall my system and try again.
Thanks for your patient help.

comment:16 by Tim Kosse, 6 years ago

Resolution: worksforme
Status: newclosed

Closing ticket as it does not appear to be an issue in FileZilla. There have been no further reports of corruption by other users.

Note: See TracTickets for help on using tickets.