Opened 7 years ago

Closed 6 years ago

#10268 closed Bug report (fixed)

r6137 breaks Windows build due to inclusion of process.h

Reported by: Ken Hornstein Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version:

Description

I'm using the version of MinGW specified in the build notes for Windows. As part of r6137, a process.h was included in FileZilla 3; this conflicts with the process.h that is shipped with MinGW, causing the build to fail (it fails with a bunch of undefined symbols; the root cause here is pthread.h is including process.h, picking up the FileZilla one instead of the MinGW one and causing the errors).

I renamed the FileZilla process.h to fzprocess.h and changed the include files everywhere, and that seemed to solve the problem.

Change History (1)

comment:1 by Tim Kosse, 6 years ago

Resolution: fixed
Status: newclosed

Fixed in r6710

Note: See TracTickets for help on using tickets.