Opened 5 years ago

Closed 5 years ago

#10174 closed Feature request (duplicate)

Add the ability to do File Diffs from within the FileZilla UI

Reported by: Anthony van Orizande Owned by:
Priority: normal Component: FileZilla Client
Keywords: File Diff Cc:
Component version: Operating system type:
Operating system version:

Description

Directory comparison and synchronised browsing are great features in Filezilla but the one thing that is missing is the ability to quickly do a diff between the server and the client versions of a file.

This feature could be implemented by downloading the server version into a temporary file and then doing a diff using whatever diffing utility that the user has installed (meld, winmerge, beyondcompare, etc..)

FileZilla would need some UI to allow the user to be able to select their diff tool of choice.

If the user then makes changes to the temporary file then FileZilla should offer to upload those changes to the server. To implement this, FileZilla would need to watch the process that was opened for the diff tool and wait till it closes.

The request and the reasoning is described in this forum article quite well.

https://forum.filezilla-project.org/viewtopic.php?t=10824

I did a quick check and did not find any actual ticket for this issue.

Change History (2)

comment:1 Changed 5 years ago by Anthony van Orizande

Type: Bug reportFeature request

comment:2 Changed 5 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #2837

Note: See TracTickets for help on using tickets.