Opened 6 years ago

Closed 6 years ago

#10165 closed Bug report (fixed)

Proxy ignored for SFTP connections (Regression from 3.9.0.6)

Reported by: Gravewish Owned by:
Priority: normal Component: FileZilla Client
Keywords: proxy, sftp Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 x64

Description

Since version 3.10.0, connections through SFTP always ignore any proxy settings I might have configured. 3.9.6 and older do not.

I've got it configured to use a HTTP proxy, over port 443. The "Bypass Proxy" setting for the connection I use is not checked.

The console shows the following lines (after enabling detailed output):

Response:	fzSftp started
Command:	proxy 1 "proxy.domain.com" 443
Command:	open "user@site.com" 2222

But then it actually does a direct connection instead. I confirmed this by looking at my firewall's network connections view, netstat, and by the fact that I'm no longer speed-limited by the proxy.

I've downgraded until the issue disappeared, and found that the proxy 3.9.6 and older versions do not have this issue.

I assume it's caused by the "Updated SFTP components from PuTTY" change introduced in 3.10.0-beta3, but I might be wrong.

Change History (4)

comment:1 by Gravewish, 6 years ago

Summary: Proxy ignored for SFTP connections (Regression from 3.9.6)Proxy ignored for SFTP connections (Regression from 3.9.0.6)

I re-read the description before posting multiple times, but didn't manage to notice that I wrote 3.9.6 instead of 3.9.0.6 until after submitting... I'm sorry for that.

comment:2 by Tim Kosse, 6 years ago

This happens if there's a session stored in PuTTY for hostname you are trying to reach.

This session is implicitly loaded and unfortunately overwrites the proxy settings

in reply to:  2 comment:3 by Gravewish, 6 years ago

Replying to codesquid:

This happens if there's a session stored in PuTTY for hostname you are trying to reach.

This session is implicitly loaded and unfortunately overwrites the proxy settings

Thanks for the reply.

Just tested with different domains and this seems to be reproduce-able. As a workaround, I have temporarily changed the sub-domain used in FileZilla for SFTP so that my SSH session saved in PuTTY has a different host-name (it's still pointing to the same server, so it works). This makes it actually use the proxy.

Even then, I don't think this is correct behavior. If this can't be fixed, there should at least be a warning somewhere. I have a small, strict bandwidth limit at full-speed (12MB/s) without using a proxy. Through the proxy there's no limit, but I'm speed-limited to 1MB/s instead. I usually transfer stuff from/to my server through FileZilla (as I do so quite often) over the proxy to avoid wasting bandwidth, but this bug made me waste almost half of my month's bandwidth before I even noticed.

comment:4 by Tim Kosse, 6 years ago

Resolution: fixed
Status: newclosed

Fixed in 3.10.1

Note: See TracTickets for help on using tickets.