Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10092 closed Bug report (rejected)

FileZilla Client does not save level of debug info

Reported by: Sergey Molchanov Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version:

Description

Client version is 3.10.0.1

When started the debug level is 0.
Go to Edit -> Settings... -> Debug section.
Change
'Debug information in message log:' drop-down from '0-None' to any other, eg '1-Warning'
Click OK.
Changes applied then. Bot they are valid only for current instance of the client.
If you exit the client and start it again the debug level will revert to 0-None

Also there isn't any key to store the value in
%appdata%\FileZilla\filezilla.xml

The issue is reproduced both for fresh installation and for upgrading.

Change History (2)

comment:1 Changed 5 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is intentional due to the performance impact of debug logging.

comment:2 Changed 5 years ago by Tim Kosse

If you for some reason need this option to persist, compile a debug build of FileZilla or set the FZDEBUG environment variable to 1.

Note: See TracTickets for help on using tickets.