Opened 5 years ago

Closed 5 years ago

#10049 closed Bug report (duplicate)

permissions missing uploading as root

Reported by: jezer5ba Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc: GSC
Component version: Operating system type: OS X
Operating system version:

Description

After updating to 3.10.0.1 if i upload a file as root (to centos) the permissions are blanked - just set to dashes - reverting to previous version fixes the issue

Change History (6)

comment:1 Changed 5 years ago by Cássio

This doesn't occur only with the root user. Connecting with a normal user in a SFTP connection, the same problem happened to me.

comment:2 Changed 5 years ago by GSC

Cc: GSC added
Priority: normalhigh

I also experienced this. This bothers me a lot and critical for java developers. Since if my uploaded jar has no permission, I cannot run the jar and get errors that is hard to think of as such a permission issue. Please fix this ASAP.

comment:3 Changed 5 years ago by Mike

please inform how to revert version

comment:4 Changed 5 years ago by Danny Pesses

This has been happening to me as well, although I did notice it occurring in version 3.10.0.0 as well.

Steps to reproduce:

  1. Connect to a server using SFTP.
  2. Upload a file to a folder in which you have read/write access. (Issue does not affect new folders.)
  3. Refresh the server directory window.
  4. View newly uploaded file's permissions under the Permissions column in the server directory. (Alternatively, right-click/option-click newly uploaded file and select File Permissions.) The file will not have been given any read, write or execute permissions; however, you are still able to manually change the file's permissions as normal.

comment:5 in reply to:  3 Changed 5 years ago by GSC

Replying to mkirkman:

please inform how to revert version

You can download old version here: http://sourceforge.net/projects/filezilla/files/FileZilla_Client/

comment:6 Changed 5 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.