Ticket #8188 (closed Patch: fixed)

Opened 21 months ago

Last modified 20 months ago

filezilla-3.5.3 invalid conversion error during compilation

Reported by: stijn Owned by:
Priority: normal Component: FileZilla Client
Keywords: compiling error Cc:
Operating system type: Linux Operating system version: SUSE Linux

Description

Making all in .
make[1]: Entering directory `/home/slemmens/Downloads/software/filezilla-3.5.3'
make[1]: Nothing to be done for `all-am'.
make[1]: Leaving directory `/home/slemmens/Downloads/software/filezilla-3.5.3'
Making all in src
make[1]: Entering directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src'
Making all in include
make[2]: Entering directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src/include'
make all-am
make[3]: Entering directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src/include'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src/include'
make[2]: Leaving directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src/include'
Making all in engine
make[2]: Entering directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src/engine'
make all-am
make[3]: Entering directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src/engine'
g++ -DHAVE_CONFIG_H -I. -I../../src/include -I./../include -I/home/slemmens/local/include -I/home/slemmens/local//lib/wx/include/gtk2-unicode-release-2.8 -I/home/slemmens/local//include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -DWXGTK -I/home/slemmens/local/include -fpch-preprocess -g -O2 -Wall -g -fexceptions -std=gnu++0x -MT libengine_a-FileZillaEngine.o -MD -MP -MF .deps/libengine_a-FileZillaEngine.Tpo -c -o libengine_a-FileZillaEngine.o test -f 'FileZillaEngine.cpp' || echo './'FileZillaEngine.cpp
/usr/include/c++/4.3/ext/new_allocator.h: In member function ‘void gnu_cxx::new_allocator<_Tp>::construct(_Tp*, _Args&& ...) [with _Args = int, _Tp = CNotification*]’:
/usr/include/c++/4.3/bits/stl_list.h:480: instantiated from ‘std::_List_node<_Tp>* std::list<_Tp, _Alloc>::_M_create_node(_Args&& ...) [with _Args = int, _Tp = CNotification*, _Alloc = std::allocator<CNotification*>]’
/usr/include/c++/4.3/bits/stl_list.h:1349: instantiated from ‘void std::list<_Tp, _Alloc>::_M_insert(std::_List_iterator<_Tp>, _Args&& ...) [with _Args = int, _Tp = CNotification*, _Alloc = std::allocator<CNotification*>]’
/usr/include/c++/4.3/bits/stl_list.h:881: instantiated from ‘void std::list<_Tp, _Alloc>::push_back(_Args&& ...) [with _Args = int, _Tp = CNotification*, _Alloc = std::allocator<CNotification*>]’
FileZillaEngine.cpp:111: instantiated from here
/usr/include/c++/4.3/ext/new_allocator.h:114: error: invalid conversion from ‘int’ to ‘CNotification*’
make[3]: *** [libengine_a-FileZillaEngine.o] Error 1
make[3]: Leaving directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src/engine'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src/engine'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/slemmens/Downloads/software/filezilla-3.5.3/src'
make: *** [all-recursive] Error 1

Configured with:
./configure --prefix=/home/slemmens/local/ CPPFLAGS=-I/home/slemmens/local/include --with-idn-lib=/home/slemmens/local/lib/libidn.so PKG_CONFIG_PATH=/home/slemmens/local/lib/pkgconfig/ --with-tinyxml=builtin --without-dbus

wxWidgets configuration:
./configure --prefix=/home/slemmens/local/ --with-gtk --enable-unicode

Dependencies:
gettext-0.18.1.1
gmp-5.0.5
gnutls-2.12.20
libidn-1.25
nettle-2.5
p11-kit-0.13
sqlite-autoconf-3071300
wxWidgets-2.8.12
xdg-utils-1.1.0-rc1

GCC:
gcc -v
Using built-in specs.
Target: x86_64-suse-linux
Configured with: ../configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.3 --enable-ssp --disable-libssp --with-bugurl= http://bugs.opensuse.org/ --with-pkgversion='SUSE Linux' --disable-libgcj --disable-libmudflap --with-slibdir=/lib64 --with-system-zlib --enable-cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --program-suffix=-4.3 --enable-linux-futex --without-system-libunwind --with-cpu=generic --build=x86_64-suse-linux
Thread model: posix
gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux)

Attachments

8188.patch Download (500 bytes) - added by esminis 21 months ago.

Change History

Changed 21 months ago by esminis

Changed 21 months ago by esminis

It looks like there is some problem with compiler templates(cannot reproduce thou), attached patch to fix this.

Changed 21 months ago by ci-dev

  • type changed from Bug report to Patch

Changed 20 months ago by stijn

This patch fixed the problem for me.

Changed 20 months ago by codesquid

  • status changed from new to closed
  • resolution set to fixed

Thanks, applied.

Note: See TracTickets for help on using tickets.