Opened 15 years ago

Last modified 14 years ago

#998 closed Bug report

Setting advanced file attributes

Reported by: kkoehne Owned by: Alexander Schuch
Priority: normal Component: FileZilla Client
Keywords: Cc: kkoehne, Alexander Schuch, hvandervegt, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

When setting remote file attributes via the GUI, the
client changes the permission set.

E.g. when setting the set-group-ID-on-execution bit, I
enter "2777" in the mask of "Change file attributes"
("Dateiattribute ändern" in the german version). When
applied, the client sends following FTP commands:

Befehl: SITE CHMOD 50777 /public_html/tmp
Antwort: 200 SITE CHMOD command successful

Which is just plain wrong: It should execute "SITE
CHMOD 2777 /public_html/tmp" instead.

For details on the group-ID-on execution bit, see the
man pages for chmod.

Change History (4)

comment:1 by hvandervegt, 15 years ago

Indeed setting the s (SUID GUID) bits or t(STICKY) bit is
not working.
It would be fine if this could be solved.

Henry

comment:2 by Alexander Schuch, 14 years ago

Can you please try latest FileZilla 2 or even FileZilla 3 beta to see if the problem still
persists?

comment:3 by Alexander Schuch, 14 years ago

I tried FileZilla 3 beta and only the three lowest significant octets are used for the CHMOD command. But this might be a limitation of the used FTP server, so better try yourself again.

comment:4 by Tim Kosse, 14 years ago

Should have be fixed in most recent 2.x versions.

Ci-Dev, I've just committed a fix for FZ3 as well.

Note: See TracTickets for help on using tickets.