Opened 5 years ago

Closed 5 years ago

#9948 closed Bug report (rejected)

Client to server issues

Reported by: George Owned by:
Priority: normal Component: FileZilla Server
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: 7 & 8

Description

I am running fz Client on 1 pc with win 7 and on another pc i am running win 8 with fz server. i am trying to connect the two... I have made the connection but when i try to create a new file i get an error..

here is what the server side shows:


FileZilla Server version 0.9.48 beta
Copyright 2001-2014 by Tim Kosse (tim.kosse@…)
https://filezilla-project.org/
Connecting to server 127.0.0.1:14147...
Connected, waiting for authentication
Logged on
(000013)12/17/2014 18:14:32 PM - (not logged in) (192.168.2.3)> Connected on port 21, sending welcome message...
(000013)12/17/2014 18:14:32 PM - (not logged in) (192.168.2.3)> USER admin
(000013)12/17/2014 18:14:32 PM - (not logged in) (192.168.2.3)> 331 Password required for admin
(000013)12/17/2014 18:14:32 PM - (not logged in) (192.168.2.3)> PASS *
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> 230 Logged on
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> SYST
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> 215 UNIX emulated by FileZilla
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> FEAT
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> PWD
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> 257 "/" is current directory.
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> TYPE I
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> 200 Type set to I
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> PASV
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> 227 Entering Passive Mode (192,168,2,2,198,116)
(000013)12/17/2014 18:14:32 PM - admin (192.168.2.3)> MLSD
(000013)12/17/2014 18:14:38 PM - admin (192.168.2.3)> 426 Connection timed out, aborting transfer of "/"
(000013)12/17/2014 18:14:38 PM - admin (192.168.2.3)> 421 Connection timed out.
(000013)12/17/2014 18:14:38 PM - admin (192.168.2.3)> disconnected.
(000014)12/17/2014 18:14:51 PM - (not logged in) (192.168.2.3)> Connected on port 21, sending welcome message...
(000014)12/17/2014 18:14:51 PM - (not logged in) (192.168.2.3)> USER admin
(000014)12/17/2014 18:14:51 PM - (not logged in) (192.168.2.3)> 331 Password required for admin
(000014)12/17/2014 18:14:51 PM - (not logged in) (192.168.2.3)> PASS
*
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> 230 Logged on
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> CWD /
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> 250 CWD successful. "/" is current directory.
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> PWD
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> 257 "/" is current directory.
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> TYPE I
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> 200 Type set to I
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> PASV
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> 227 Entering Passive Mode (192,168,2,2,198,117)
(000014)12/17/2014 18:14:51 PM - admin (192.168.2.3)> MLSD
(000014)12/17/2014 18:14:57 PM - admin (192.168.2.3)> 426 Connection timed out, aborting transfer of "/"
(000014)12/17/2014 18:14:57 PM - admin (192.168.2.3)> 421 Connection timed out.
(000014)12/17/2014 18:14:57 PM - admin (192.168.2.3)> disconnected.

And here is what the Client side shows:


Status: Connecting to 192.168.2.2:21...
Status: Connection established, waiting for welcome message...
Response: 220 FBI SERVER CONNECTION ESTABLISHED
Command: USER admin
Response: 331 Password required for admin
Command: PASS *
Response: 230 Logged on
Command: SYST
Response: 215 UNIX emulated by FileZilla
Command: FEAT
Response: 211-Features:
Response: MDTM
Response: REST STREAM
Response: SIZE
Response: MLST type*;size*;modify*;
Response: MLSD
Response: UTF8
Response: CLNT
Response: MFMT
Response: EPSV
Response: EPRT
Response: 211 End
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is current directory.
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (192,168,2,2,198,116)
Command: MLSD
Response: 426 Connection timed out, aborting transfer of "/"
Error: Failed to retrieve directory listing
Response: 421 Connection timed out.
Error: Connection closed by server
Status: Connecting to 192.168.2.2:21...
Status: Connection established, waiting for welcome message...
Response: 220 FBI SERVER CONNECTION ESTABLISHED
Command: USER admin
Response: 331 Password required for admin
Command: PASS
*
Response: 230 Logged on
Status: Connected
Status: Starting upload of C:\Users\My Dojo Marketing\AppData\Local\Temp\fz3temp-1\empty_file_yq744zm
Command: CWD /
Response: 250 CWD successful. "/" is current directory.
Command: PWD
Response: 257 "/" is current directory.
Status: Retrieving directory listing...
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (192,168,2,2,198,117)
Command: MLSD
Response: 426 Connection timed out, aborting transfer of "/"
Command: SIZE index.php
Error: Could not read from socket: ECONNABORTED - Connection aborted
Error: Disconnected from server
Error: File transfer failed


and yes, I like to feel important so i made my server welcome message FBI SERVER CONNECTION ESTABLISHED... Don't judge... LMAO

Change History (2)

comment:1 Changed 5 years ago by Tim Kosse

Priority: criticalnormal

comment:2 Changed 5 years ago by Alexander Schuch

Resolution: rejected
Status: newclosed

Command: PASV
Response: 227 Entering Passive Mode (192,168,2,2,198,117)
Command: MLSD
Response: 426 Connection timed out, aborting transfer of "/"

Your FTP client tries to connect to the server, but the server does not accept a connection at port 50805. Maybe it is firewalled?

Please read and understand how to set up your network. So for now, this is not a bug, but a network setup problem.

Note: See TracTickets for help on using tickets.