Opened 5 years ago

Closed 5 years ago

#9889 closed Bug report (fixed)

CPU load 99% during Idle

Reported by: pyro Owned by: Tim Kosse
Priority: normal Component: FileZilla Client
Keywords: wxWidgets Cc:
Component version: Operating system type: Linux
Operating system version: OpenSuse 13.2

Description

I am using filezilla 3.9.0.6 on linux with wxWidgets 3.0.2.

After starting filezilla, without connecting to a server or doing anything, the filezilla process uses 99% of a CPU Core, and the X-Server process raises its CPU load from 1% to about 60%.

Attachments (1)

filezilla.gprof (110.1 KB) - added by pyro 5 years ago.
gprof log

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by pyro

Attachment: filezilla.gprof added

gprof log

comment:1 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

What's your Linux distribution?

What's your Window manager?

Are you using the binaries from the FileZilla website or have you build FileZilla yourself?

comment:2 Changed 5 years ago by pyro

Status: moreinfonew

The distribution is Exherbo, the window manager i3 and I build filezilla from source.

comment:3 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

I'm not familiar with that distribution, nor with the used window manager.

From the gprof output it seems something is causing excessive redraws of the main window.

To narrow down the issue further, can you reproduce the issue if using a different, more mainstream window manager, e.g. the one from Xfce, Gnome or KDE?

comment:4 Changed 5 years ago by pyro

Operating system version: OpenSuse 13.2
Status: moreinfonew

I can reproduce the Error on OpenSuse 13.2 and KDE4.
Just compiled wxWidgets 3.0.2 and filezilla 3.9.0.6 from source.

comment:5 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

I have been unable to reproduce it on a fresh openSUSE installation.

What's wxWidgets linked against for you? GTK+2, GTK+3 or some other toolkit?

Please post the output of the following two commands from wxWidgets:
wx-config --cppflags
wx-config --libs

comment:6 Changed 5 years ago by pyro

Status: moreinfonew

GTK+3

wx-config --cppflags

-I/usr/lib64/wx/include/gtk3-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -DWXGTK

wx-config --libs

-L/usr/lib64 -pthread -lwx_gtk3u_xrc-3.0 -lwx_gtk3u_html-3.0 -lwx_gtk3u_qa-3.0 -lwx_gtk3u_adv-3.0 -lwx_gtk3u_core-3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0

comment:7 Changed 5 years ago by Tim Kosse

Owner: set to Tim Kosse
Status: newaccepted

Building wxWidgets against GTK+3 I managed to reproduce this issue.

It's an issue in wxWidgets as it is also reproducible in wx' own listctrl sample.

The cause is still unknown to me, I need to further analyze this.

Workaround: Build wxWidgets against GTK+2 by adding --with-gtk=2 to the configure arguments.

comment:8 Changed 5 years ago by Tim Kosse

Filed under the following upstream ticket: http://trac.wxwidgets.org/ticket/16668

comment:9 Changed 5 years ago by Tim Kosse

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.