Opened 5 years ago

Closed 5 years ago

#9885 closed Bug report (duplicate)

Commands sent in wrong order when uploading directories, resulting in files not uploaded

Reported by: teo8976 Owned by:
Priority: low Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Linux
Operating system version: ubuntu 14.04

Description

Steps to reproduce:

  • connect to a server
  • on the local side (left), select a few folders
  • right-click and upload

Expected result:

  • for each folder, it should OBVIOUSLY first create the folder, then upload the files.

Observed results:

  • for each folder, systematically, the "put" command to upload the first file in the folder is sent BEFORE the mkdir command to create the folder. So, unless the folder already existed on the server, that file upload gives an error and is not uploaded.

ALSO, whenever a file gives an error it should be kept in the queue so that you can retry!!!

This level of unreliability make FileZilla completely unusable. You have to check all the files one by one, because there may have been any such random error and you wouldn't even know.

I think this is a regression. I have used FileZilla for ages and had never seen such a thing before.

Example log when uploading a folder called "runtime" within one called "protected":

Status: Starting upload of /home/teo/Documents/xxxxx/protected/runtime/application.log.4
Error: Directory /srv/www/xxxxx/protected/runtime: no such file or directory
Command: cd "/srv/www/xxxxx/protected"
Response: New directory is: "/srv/www/xxxxx/protected"
Command: mkdir "runtime"

Change History (1)

comment:1 Changed 5 years ago by Tim Kosse

Priority: criticallow
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.