Opened 7 years ago

Closed 7 years ago

#9797 closed Bug report (fixed)

Rename file/folder program crash

Reported by: Ramzes Owned by: Tim Kosse
Priority: normal Component: FileZilla Client
Keywords: crash, client, rename Cc:
Component version: Operating system type: Windows
Operating system version: Windows 8 64-bit

Description

Hi,

When you try to rename something while already in rename mode, the client crashes.

e.g.
When you're browsing files in the file list, whether local or online, it's possible to click a file and then click it again to rename it,

but right before the filename gets selected and 'rename mode' is entered, it's possible to right-click the file and get the normal context menu.

By then clicking 'Rename', the client crashes.

Screenshots:

http://puu.sh/b1N0f/b92fa51142.png
http://puu.sh/b1N0R/22b158a2c1.png

Change History (4)

comment:1 by Bruno Ramos, 7 years ago

Status: newmoreinfo

Could you please confirm which version of FileZilla you are using?

Note: Cannot reproduce this in Debian GNU/Linux with either 3.9.0.1(from repos) or with trunk.

comment:2 by Tim Kosse, 7 years ago

Status: moreinfonew

Confirmed.

comment:3 by Tim Kosse, 7 years ago

Owner: set to Tim Kosse
Status: newaccepted

comment:4 by Tim Kosse, 7 years ago

Resolution: fixed
Status: acceptedclosed

A fix has been committed to the repository.

Note: See TracTickets for help on using tickets.